C-Command Software Forum

Console & AppleScript Errors

Where in the Console do I look to review AppleScript errors, and how do I interpret them?

When running the EagleFiler script, Remove Duplicate Messages, a dialog box appeared suggesting that I could review the errors in the Console app.

2019-07-28_11-06-46.jpg

When I opened the Console, I did see several lines, but I didn’t see “14 unexpected log entries.” Instead I saw a very large list that seemed to be truncated. I wasn’t even sure if any of these were errors becasue they just refered to duplicates. Perhaps the truncation was due to length?

Then I poked around different parts of the Console and couldn’t get back the EagleFiler-AppleScript entries. I tried using Find > Filter using the terms “EagleFiler” and “AppleScript”, and I tried creating a System Log Query using the same terms, but I couldn’t figure out how to return to the log entries.

Now I’m not sure if I should click Ignore the Errors, re-run the script, and/or something else. Mostly, I would like to know exactly what went wrong with this particular run of the script. FYI, the Mailbox I was processing contained approximately 22,000 messages, and I expected about half to be dupes.

Please advise.

The script should be opening a separate log file in Console (not the All Messages log) that only contains information from this run of the script. The lines that say “Duplicate key found” are normal, but in this case it’s saying that there were 14 other lines that don’t say that. Those are the ones that are potentially interesting.

Thank you! It seemed to appear when I first opened Console, but then I navigated away to another part of the utility, and I couldn’t figure out how to get back to the log. Is it still available somewhere? If so, what is the log called and where in the heirarchy will I find it?

Assuming it is still available for viewing, is it in the Files section of Console where lots of logs appear to reside? If so, where exactly within? There appear to be hundreds of logs in there, and I didn’t see any names that were obvious.

2019-07-28_13-35-16.jpg

It should be called Log.log and available in the File > Open Recent menu. The containing folder has EFRemoveDuplicateMessages in the name.

Okay, thanks, Michael. So, in analyzing the log, it appears that the “errors” may be due to extra line breaks that were added to accommodate log entries that were too long to fit entirely on a single line. EagleFiler reported 14 errors, and I saw exactly 14 instances of extra line breaks within ~10,000 line log.

See the highlighted portion of the attached image for an example of what an extra line break looks like in the Console app.

2019-07-28_15-48-09.jpg

Is this expected behavior? Or does it appear to be a bug?

I don’t think I’ve seen the formail tool break lines like that before, but if that’s all that’s happening here (i.e. it’s not just wrapping for display purposes because the window is too narrow), there’s nothing to worry about.