C-Command Software Forum

Corrupted library

I got this message after upgrading from Tiger to Leopard. What am I supposed to do to fix the library? I am running Eaglefiler 1.3, OS X 10.5.2.

The first message is an internal error from Core Data. How did you update to Leopard? It looks like EagleFiler’s database file was damaged in the transition, and possibly some of your folders have incorrect permissions. If you have a backup from before the Leopard update, you should restore from it. Otherwise, you could create a new library and then drag the Files folder from the old library onto EagleFiler’s Dock icon. This will copy all the files (and metadata) to a new library with a fresh database.

Used the second option and now everything seems to be working fine. Thanks a lot.