C-Command Software Forum

Could Not Launch SpamSieve

After upgrading to Tiger 10.4.11 (PPC) and applying Security Update 2007-009 SpamSieve no longer launches when spam messages are received in Mail or when its icon is double clicked in the Applications folder or in the Dock. Upon receiving spam messages Mail tries to launch SpamSieve and the following error message appears: Could Not Launch SpamSieve; Mac OS X reported error 5 when trying to launch SpamSieve.

I have downloaded a fresh copy of SpamSieve 2.6.5 and trashed the old one. The new copy likewise does not launch. The User/Library/Mail/Bundles folder contains only the SpamSieve.mailbundle folder.

I would be very grateful for your help.

Further to my earlier message, the SpamSieve crash log reports:

Command: SpamSieve
Path: /Applications/SpamSieve.app/Contents/MacOS/SpamSieve
Parent: WindowServer [74]

Version: 2.6.5 (2.6.5)

PID: 407
Thread: Unknown

Link (dyld) error:

Library not loaded: /System/Library/Frameworks/AppleScriptKit.framework/Versions/A/AppleScriptKit
Referenced from: /Applications/SpamSieve.app/Contents/MacOS/SpamSieve
Reason: no suitable image found. Did find:
/System/Library/Frameworks/AppleScriptKit.framework/Versions/A/AppleScriptKit: unknown file type, first eight bytes: 0x77 0x65 0x72 0x28 0x41 0x53 0x4B 0x43
/System/Library/Frameworks/AppleScriptKit.framework/Versions/A/AppleScriptKit: unknown file type, first eight bytes: 0x77 0x65 0x72 0x28 0x41 0x53 0x4B 0x43

Grateful your advise.

It looks like your Mac OS X installation is damaged—at minimum, the AppleScriptKit framework that SpamSieve depends upon. I guess you’ll need to re-install the OS from DVD.

Before doing the full OS reinstall I tried a reinstall the last update mentioned in my first message. Fortunately this worked and SpamSieve launches as usual.

Many thanks for your help.