C-Command Software Forum

Crash in scriptrunner When Training as Spam

One of my clients is having exactly the same problem; however, in this case, whenever one selects “Train as Spam” from the menu, the scriptrunner process crashes. Following is a partial report from Console.app.

Host Name: Betsy-Laptop
Date/Time: 2008-01-11 14:49:50.242 -0500
OS Version: 10.4.11 (Build 8S2167)
Report Version: 4

Command: scriptrunner
Path: /Users/betsyxxxxxx/Library/Mail/Bundles/SpamSieve.mailbundle/Contents/Resources/scriptrunner
Parent: Mail [376]

Version: ??? (???)

PID: 377
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xffc9aab0

Thread 0 Crashed:
0 com.apple.applescript 0x97f2ed17 GCMakeString(unsigned long) + 43

<the rest of the CrashReporter Log has been deleted for brevity…>

Is this for all messages, or just a particular one? Have you tried reinstalling SpamSieve’s Apple Mail plug-in?

I only tried one particular message, but my client reports that it is happening with all messages she attempts to mark as spam. I did try re-installing SpamSieve. I even removed the entire SpamSieve directory under “Bundles” and re-installing. Nothing changed.

I’ve seen this crash several times before. In those cases, it happened only with certain messages (typically very large ones). My guess is that it’s caused by a bug in AppleScript, so I would not expect reinstalling or changing SpamSieve to help.

If it used to work fine for your client, but now it consistently crashes, I’d suggest trying to find out what’s changed on her Mac. It might work in a fresh Mac OS X user account or after reinstalling the OS.

Secondly, I’d be interested to know whether the crash happens if you train SpamSieve by running the attached AppleScript in Script Editor rather than via Mail’s Message menu.