C-Command Software Forum

Custom Icon

Unable to persuade DropDMG to honour my selection for producing a custom volume icon.

(It’s not clear to me whether the checkbox “Custom volume icon” should be selected but I have tried with and without it selected and still no luck.)

I chose a .png file of a .png that is 512x512 and can confirm that a .Volumeicon.icns is produced and that it is correct in that the icon appears as expected.

Yet when the .dmg is produced it instead is displayed with the folder icon that is the main directory on the volume.

(I’m deploying a folder containing icons rather than a single App).

I’ve tried saving the .Volumeicon.icns into the source folder but still no luck.

Any suggestions?

Simon
Australia

Yes, you’re first supposed to save the .VolumeIcon.icns file in the top level of the folder that you’re dropping onto DropDMG. Then make sure that Custom volume icon is checked when you create the disk image.

Does it work if you try it with a different source folder and icon?

Great. Got it working. As I’m creating a volume that contains a folder I assumed it was that folder that should contain the .Volumeicon.icns file. When I selected the source folder as the destination for the saved graphic it worked as expected.

It’s not really clear what’s going to happen until you do build a volume.

It would be useful if you’ve selected a graphic file and checked the checkbox or if you have checked the checkbox and haven’t selected a graphic to see the graphic that DMG is going to use before building.

But it more than does the job and I’m buying a copy now I’ve got that sorted out.

Simon

Great!

I agree that this should be clearer. It’s a tough interface design problem because the preferences window shows options that can be used for any source folder. DropDMG doesn’t know which source folder you’re going to give it until you actually tell it to make the disk image.