C-Command Software Forum

Delayed sound on YouTube

Hello, I’m using ToothFairy to connect to my Tronsmart Onyx Ace headphones, which sound nice (and are quite cheap as well :slight_smile: )
When I’m trying to watch YouTube on Safari, the sound is not in sync with the video and sometimes it breaks/stutters. I have no problems with sound on the phone call or zoom meetings.

I expected from Toothfairy a possibility to watch YouTube on microphone-less BT connection.
(I tried to set it in Fairy’s device advanced menu but to no avail).

best,
Marcin

Sorry to hear that your audio is delayed. I’m not sure what’s causing that. ToothFairy is only involved in initiating the connection, not in transmitting the sound to the headphones. You may want to try unchecking Improve sound quality by disabling audio input from device, as there could be a problem with the higher quality codec (which would be used for YouTube but not Zoom).

Could you explain more specifically what didn’t work the way you expected?

Hello Michael,

I was trying to use earbuds with the option “Improve sound quality by disabling audio input from device” both disabled and enabled. I expected, that it will change the Bluetooth protocol used to connect to earbuds and remove the delay.

Please note that that option only takes effect when you connect the headphones. Changing it after they are connected will not affect the current connection.

Which version of macOS are you using?

Thank you, I was disconnecting headphones to test this option. I was also restarting bluetooth, resetting bluetooth module, clearing PRAM and so on :slight_smile:
I’m using Big Sur 11.2.1 on Macbook Pro Mid 2015.

On my iPhone there’re no problems with those earbuds.

You’re trying all the things I would suggest. It could be a Mac-specific Bluetooth bug. Or perhaps there’s wireless interference near your Mac. Have you tried using those headphones with your MacBook Pro in different locations?

I’ve tried… I’ve even tested them on my old Macbook Pro from 2011 - and they work OK. So it must be my computer’s problem, either Big Sur or other software/configuration… Do you know other tools to investigate the situation?

Have you tried a different macOS user account on the same Mac?

Apple has a Bluetooth Explorer app (but may require a developer account to download it).