C-Command Software Forum

disable search as you type in search box

Is there a way to keep EF from searching as soon as one begins typing in the search box? Is there perhaps a preference for this or a terminal command to set the wait time before searching begins?

When I start typing in the search box, I get a spinning ball before I’ve written more than two letters and can’t continue typing until EF returns the huge list of hits which are inevitable with such a short search string.

I would like EF to wait for an enter command to start searching, but just making it temporize and give me five seconds to type my search phrase would be a significant improvement.

Thanks for help with this,

Morton

EagleFiler uses the standard system delay in order to determine when to start searching. If you want to type slower, you can use the SendsWholeSearchString esoteric preference so that it only searches when you press Return.

Another option would be to uncheck Match Partial Words, which is probably part of the cause of such a large results list.

Thanks, MIchael, for the timely reply. This fixes my issue.
I had tried unchecking partial word searches, but preferred being able to use that functionality.