C-Command Software Forum

Eagle Filer and Spaces

I am a heavy user of spaces and I am having an issue with the tag cloud and tag window not staying tethered to the main application and floating to all the other spaces. I understand that the Drop Pad should work this way, but I prefer to not have to close the tag windows every time leave the Eagle Filer application. This problem has been around now for the last couple of versions. Any suggestions?

Using OS X 10.5.6 and Eagle filer 1.4.8.

I’m sorry, but I don’t understand what you’re saying the problem is or what you’re suggesting. The current behavior is that the Tag Cloud and Tags window auto-hide when EagleFiler is not the frontmost application. So I don’t see why you would need to close them.

Eagle Filer resides in space 4 where I have permanently assigned it. When I switch to any other space 1,2,3,5 or 6 using the keyboard, the tag cloud and tags windows go along for the ride while the main library window stays put. They do auto-hide when I click on another application but it would be better if they stayed in space 4 where they belong.

Also, when I drag something into the Drop pad in another space, the same two windows pop up. I have a lot of tags so the windows take up a bit of space on my 15" screen.

I believe that the windows are following the drop pad as the only way I have found to avoid this is to disable the drop pad.

I hope this makes more sense, thank you.

Thanks for explaining. EagleFiler creates the inspectors as normal windows, and it’s not doing anything differently with them compared to previous versions. They are using the default Spaces behavior, which means that the OS determines when to move them to a different space. The alternative is to tell the OS to put them on all spaces (which is clearly not what you want). There is, as far as I know, no mechanism to tell the OS to make them stay put.

I think the difference you observed is that starting with EagleFiler 1.4.6 the Drop Pad is set to appear in all spaces. When you change spaces, the OS will detect that there’s a window present, so it will decide to move the inspectors. To prevent this, I think you would need to hide the Drop Pad or set it to only appear on one space. You can do that by clicking this link. To revert to the normal behavior of the Drop Pad appearing on all spaces, click here.

Thank you very much for your help. I have turned off the drop pad in all spaces for now and all is well.

I also had an odd behavior with Spaces & EagleFiler. I have EagleFiler assigned to Space 1, and have both Info & Drop Pad windows open. Drop pad shows up on other spaces as expected, and Info does not also expected.

The problem is when I alt-tab from other spaces to EagleFilter, the Info window shows up on whichever current space i’m in. It does not switch to Space 1. Instead, the Info shows up (on current space), and the main viewer does not (not what i want anyways).

After reading this thread, i closed DropPad, and now it behaves as expected. Alt-tab from any spaces other than it switches me to space 1 w/ EagleFiler all up front.

with 10.6.1