C-Command Software Forum

Eagle Filer use without copying all FILES possible

I am puzzled.
I thought Eagle Filer puts a database with indexing based on my existing folders.
However when I - import - files they are going to be copied to the database folder.
Which basically means now I am using the double space and I have the files double as well.
Is there any way to use EagleFiler - without - physically copying all data and files?

Best Bernd

That’s correct, however the folders need to be inside EagleFiler’s Files folder. You can choose whether to move or copy them.

If you’re using macOS 10.13 or later, even if you opt to “copy” it won’t use double the space. EagleFiler will use APFS file cloning to make sure that the blocks on disk are shared between the two copies of the files.

Well then the next question would be which files will I open for edit and will both copies be updated?

The copies share space on disk but are distinct files. Editing one will not change the other. If you only want to have one file, you should move it into EagleFiler instead of copying.

Unfortunately, that’s a real knockout for me.
Moving everything to Eagle Filer is not an option and having two files neither.

You can also use symlinks to store certain folders of your EagleFiler library at other locations, if you don’t want to move them. See “Aliases and Symlinks” at the bottom of this page.

Hi Michael,
Sorry but I do not fully understand that page
This is what I tried

Created a new library under my home folder
copied a short cut of one of my data folder into the files folder
But double click opens the files in Finder so I cannot assign and tag at all.

Best Bernd

First create the folder within EagleFiler. Then you can replace the folder with a symlink to your actual folder:

  1. In EagleFiler, create an empty folder called Data.

  2. Close the library in EagleFiler.

  3. In Finder, delete the empty Data folder.

  4. Create the symlink. For example, if your EagleFiler library is called EFLibrary and is in your Documents folder, and the actual Data folder is also in the Documents folder, you would enter this command in Terminal:

    ln -s ~/Documents/Data ~/Documents/EFLibrary/Files/Data
    

OK, I did exactly like described.
I see the data folder in EF but when I open it there is nothing inside.
When I repeat the command it says “file exists”

Stuck

Best Bernd

If you go to the library’s Files folder in Finder, does the Data folder have the expected contents?


There is nothing that I can see or that is going to be indexed.
I am really lost.

I’d love to have a database on top of my data files.

Best Bernd

It looks like the symlink you created is not pointing to a valid folder. What is the folder that you want it to reference, and what is the command that you typed into Terminal?

I copied your command which should point to documents

What is confusing to me is why do I delete the data folder after ì created it in EF?

The command I gave is for linking the Data folder in EagleFiler to the Data folder in your Documents folder. It does not look like your Documents folder has a Data folder. What’s the name of the folder that you want to link EagleFiler to?

Because you are replacing the folder with a link.

OK, got it.
So can I do a link directly to the documents folder then or to the downloads folder etc.?
And it will show the content of the folder automatically and I can assign tags.

Best Bernd

You probably want to link to a subfolder of the Documents folder. Right now your EagleFiler library itself is in the Documents folder, and you don’t want to create a circle where the library contains itself.

Yes. And you should follow the Rules for Library Folders when modifying the contents of the folder from outside of EagleFiler.

Michiel, I am trying to understand the logic behind your software - to get it running.
But for now I am doing trial and error.

Created a database in the home folder
Did a data folder, deleted and pointed the downloads to it worked I can see the documents
Tried to do a second folder in files name it documents and point documents to it - failed
Tried to point documents to the DATA folder in EF - failed

So at the moment I was able to get one folder Downloads displayed.
Getting another folder in failed - so far.