C-Command Software Forum

EagleFiler can't import some files with no apparent similarity

I am migrating over from an old computer with Mojave to a 2019 laptop with Monterrey. I decided to get organized before the move and created some libraries in EagleFiler. I thought the problem I’m about to describe was a Monterrey issue, but I’ve gone back and tried my old computer. It’s the same problem. I have a rather large database of INDD, PDF, PNG, JPG, TIFF, and PSD files, amongst others. I also have some bookkeeping folders with excel and PDF files. Eaglefiler will import most of my files. However, this afternoon I needed an old PSD file that I knew existed and I knew where. It was not in the library. It and a whole bunch more files are sitting in the “Unable to Import” folder. The types of files that Eagle accepted and rejected are the same, so are the file naming systems. I tried putting one of the files in the Import folder. It just landed up as a new copy in “Unable to Import” folder. I tried dragging and dropping, restarting, re-indexing, scanning for new files. Nothing will coax Eaglefiler to accept this random collection of files that in all respects are the same as the ones it accepted. This happened on both Monterey and Mojave. Tomorrow I am going to try making a brand new library, but if that doesn’t work, I simply can’t use Eaglefiler if it won’t accept roughly 25% of my stuff. Do you have any ideas that I could try? I have used Eaglefiler in the past and liked it. I use Devonthink for items that don’t have to move around. But when creating visual stuff, you are constantly copying, linking to, moving or whatever to files. If I can’t get this fixed I may just have to use Finder. Not my first choice. So please let me know if there is anything I can do.

When putting a file in the Unable to Import folder, EagleFiler will normally open the Errors window to explain why the file couldn’t be imported. The most common reason is that the file is a duplicate and you had Allow duplicate files in library checked. You could take a look in the Errors window or send in an error report so that I can take a closer look.