C-Command Software Forum

EagleFiler Kind column not like Finder Kind column

If I drag a .webloc file into an EagleFiler library, the Kind column says it is a “Text File”. It still works as a webloc: double-click it in EagleFiler, and Safari opens the URL. So in some strong sense, it really is a webloc. So it would be nice if EagleFiler displayed the Kind as “Internet Location”, like the Finder.

Similarly for other file types: the Finder draws distinctions that EagleFiler does not. If EagleFiler has good reasons for calling everything a Text File, which is fair enough, maybe there could be another column that displays what the Finder thinks the file is?

The intended behavior is for it to show “Bookmark,” and that’s what it does on my Mac. I wonder if the problem is that it really is getting imported as a text file for you. Does the EagleFiler record viewer show the bookmark file like this:

or does it look like a text file?

Does it behave differently (vs. the file you dragged in) if you set EagleFiler’s “Web page format” to Bookmark and import a URL?

It’s certainly not the case that everything should show up as a text file. What are some other examples?

Yes, it looks like a text file (it’s XML).

So it seems that for some reason it didn’t have the .webloc suffix. I don’t know why not, and I don’t quite understand why the Finder still knows that it is a webloc (looks like a webloc, acts like a webloc) but EagleFiler doesn’t.

Other examples are, say, .md files, which the Finder calls “Markdown document” but EagleFiler calls “Text File”. Or an .rb file, which the Finder calls a Ruby Source but EagleFiler calls “Text File”. Possibly I’m now asking a completely different question? You understand, they looked like the same question to me (i.e. why is everything a Text File). :slight_smile:

That’s interesting, because if I rename a .webloc file in Finder, both Finder and EagleFiler lose track of what kind of file it is. Would you be able to create a ZIP archive of the file and send it to me so that I can investigate what’s happening here?

Yes, this seems like a different question. I will add it as a feature request. Thanks!

Unfortunately not, because when I figured out that it had lost its file extension I put the file extension back on. :slight_smile: I’ve no idea how it came to lose the extension. It was like being back in the System 6 days: it had its icon, double-clicking it opened the link in Safari, but it had no file extension. Sorry about that.

You could try renaming it back. :slight_smile:

Yes, I did that, but I didn’t get the weird behavior described in my original post. I do not know how to reproduce it, sorry. Your telling me that a webloc should be listed as something other than Text File was the clue I needed.

OK, thanks for trying. I will make a guess at what’s happening here and how to prevent it from happening again.

Sorry to come back to this, but it would be really cool if I could just create a bookmark directly in EagleFiler. In other words, let’s say I’ve copied a URL (as text), I’d like to just say “import what’s on the clipboard right now” or “New -> Bookmark” and paste the URL. I want to use EagleFilter as a URL bookmark manager without having to pass thru Safari or some other way of making a webloc as an intermediate. Might that be possible?

If you have the preferences set to use Bookmark format, you can use the File > Import URLs… command and paste in the URL.

Or if you want to import what’s on the clipboard you could run this script:

tell application "EagleFiler"
    import URLs {the clipboard} Web page format bookmark format
end tell
1 Like

I don’t see what you mean. File > Import URLs presents a file open dialog. You can’t paste into that.

It presents a sheet with a multiline text field. Please check again.

Ah! OK, I see it. That’s good enough for me, thanks!

I think this is fixed in EagleFiler 1.8.14.

Cool, thanks, downloading now.