C-Command Software Forum

EagleFiler Mail attachments problem

Hello,

Thank you for your reply to an earlier question.

I imported a mailbox in to EF and got many many errors about missing attachments. I did not have my Apple Mail client set to download attachments until yesterday. But before importing the mailbox, I created a smart mailbox of emails having attachments, and laboriously opened all of them except the ones that I had sent. When I highlight one of the error emails, and option click “Reveal” it just opens a strangely formatted copy of the email with loads of gibberish, but does not reveal it in the finder, which I thought it was supposed to do.
I was going to try the method you mention of option dragging the mailbox to “On my Mac” to make it download attachments, but I cannot do this. The mailbox refuses to be dropped there. Any idea what I’m doing wrong? Thanks.

This is explained, as I think you found, in Importing Attachments.

Reveal should show you the .emlx file in Mail’s data store (in the Finder). You can also Option-click Reveal to open the message in Mail.

Is it a special mailbox like Inbox or Sent? Mail won’t let you copy those, but the manual describes a workaround where you can temporarily map the special mailbox to a different mailbox, turning the one that you want to copy into a regular mailbox.

Thank you.
Unfortunately the reveal button did nothing when I clicked it. Option clicking just opened the gibberishy file.
As for the mailbox that couldn’t be dragged, it was the “archive” folder for gmail, which is basically all gmail.

Would you be able to e-mail some screenshots showing the error and the “gibberishy file”?

Archive is one of the special folders that you can remap in Mail’s Mailbox Behaviors settings. So the workaround that I mentioned should allow you to make a full local copy of it.

Oh how I wish I could email you the screen shots, but alas that window closed somehow and I can’t get it back. But now I have bigger problems, because I forgot your prohibition against just dragging a mailbox to “on my Mac” and did just that! So now my archive is empty, and the emails are not downloading properly if at all, in the new location (as you warned would be the case). So far I have not figured out how to restore the folder from Time Machine. On the bright side, the emails are still in their proper folder on my iMac (as opposed to the laptop) and appear to be still on Google’s server. On the less bright side, the iMac also was not set to download attachments. I’m sure this next question will reveal a glaring lack of knowledge, but will moving the archive/all mail folder to the “on my Mac” area have led Gmail to believe that I am deleting the emails, and cause it to delete them from the server? I disconnected my iMac from internet just in case.
If I can get the iMac to download the attachments, can I do the import to EF on it, and then transfer the library to my laptop via usb drive? It seems I should be able to but at this point I don’t want to make any assumptions.
Thanks!

Or here is another thought: should I delete the improperly moved folder and then put the folder from EF back in Mail, and then do that reset of the archive folder in the mailbox behaviors? The advantage of this over trying to accomplish the download of missing attachments on the iMac, is that I might mess that up too, and would not have it as a failsafe. Restoring from Time Machine doesn’t work because Mail “quit unexpectedly” every time I enter the TM.
Thanks.

To be clear, for anyone else following along, the documentation recommends that you not drag IMAP messages to an On My Mac mailbox because this will not trigger Mail to download the attachments. Mail will move them in their incomplete state. Further, it will sever the connection between the messages and the server so that the attachments cannot be downloaded in the future.

Attachments that weren’t downloaded in the first place won’t be in your Time Machine backup. You would probably need to get a backup from the mail server itself.

Hmm, that’s strange. It seems to indicate that Mail didn’t finish moving the messages. I would just quit Mail on the laptop in the hope that you can pause the process long enough to get at the messages from another device. And maybe you can copy them on the Gmail server to preserve them in a different mailbox.

If you had moved the mailbox, that tells Mail to create a copy of the mailbox, so nothing gets deleted. If you move the messages, that tells Mail to copy the messages and then delete the originals (on the server).

Yes.

No, because I don’t think you ever imported the attachments into EagleFiler, so that would lose data.

There’s a bug in macOS 10.15 where Time Machine crashes when used from within Mail, but you can still restore the folder by navigating to it in Time Machine from Finder.

Thank you for the reply. The situation is even stranger now. I had to ignore the computer for awhile, and now the folder that I dragged from the archive to “on my mac” has seemingly repopulated with intact emails. The original archive folder has also repopulated, and the computer just finished downloading files. I don’t know which mailbox this downloading message applied to, but something was downloading emails. So I have apparently dodged a disaster. My question now is can I create a whole new library to start over importing emails, without deleting the first one, until I know if the second will be an improvement? I have not knowingly deleted any emails yet that I imported. And restoring from Time Machine is an option at this point, because I can’t navigate to the mail folder in TM (it’s hidden and I can’t find it). But it doesn’t seem to be necessary. Since the Mail preferences are now set to download all attachments, and the archive folder in its original home, has gone from empty to complete, this would presumably be the folder to import, would it not?
Thanks again!

Yes, that sounds like a good idea. You can just create a new library from EagleFiler’s File menu.

To access the Library folder where Mail’s files are stored, please see this page.

Yes.

I imported the archive again, and still got the missing attachments errors. I emailed you a screen shot as you requested earlier.

Thanks.

It seems like were are back to the start, where you need to do something to get Mail to load the attachments. Either open the individual messages in Mail or do the trick to copy the whole mailbox to On My Mac.

Thanks! I thought the screenshots might contain personal info, but if they don’t feel free to post them directly in the forum.

Regarding the screenshots:

  • I do not see the “gibberishy file” that you mentioned, just the EagleFiler error window and an e-mail with “missing image” question marks.
  • It’s not clear to me why the Reveal button isn’t doing anything. It’s not affected by indexing. I will send you a debug build of EagleFiler to help figure this out.
  • It’s normal to have multiple errors with the same filename because there is one error per missing attachment and there can be multiple attachments in the same e-mail. The bottom of the window shows the number of the attachment that the selected error is referring to.
  • The “missing image” question marks are probably not related to missing attachments. If the reply never included attachments, the images would be referenced using HTML tags rather than via the message’s MIME structure, and so they don’t count as attachments and EagleFiler won’t check for them.

The gibberishy file no longer appears. Now clicking the Reveal button simply makes the error box gray out.

This is what it looks like before clicking Reveal.
This is what it looks like after.

That looks like it brought the Finder to the front. What do its windows show?

There was no finder window visible. But I put EF on my iMac and tried it there, and the Reveal button works on it. (Unfortunately I’m not sure Mail is intact there; still working on that). So now I’m wondering if somehow I failed to give EF access to control the Finder. I certainly tried to give it access to what it needs, but maybe I failed. How do I check? It has full disk access but is there another setting for Finder?
I have not yet tried the debug build.

Curiouser and curiouser! Now the Reveal button is working on the laptop too. I am not aware of doing anything different. I downloaded the debug build but haven’t installed/run it.

EagleFiler wants Automation access in System Preferences in order to import files (read their Spotlight comments). However, no access is required to reveal files in Finder.

That’s odd, because when I downloaded and started EF on the iMac this morning, it asked for permission for EF to control the finder. This was after it was granted full disk access.
Should I go ahead and do the debug thing even though the Reveal button seems to be working?

Maybe that’s how it asked for automation access, since Finder is listed under it?

Yes, that’s when it asks for Automation access. It looks like you’ve already granted that. It’s not related to the Reveal button, though.

If it’s working, there’s no need to do anything with the debug version.

I guess the only remaining issue is my disassociated attachments due to my improper movement of the mailbox, and I don’t think there’s anything I can do about that, so I’ll have to convince myself that they were unimportant. (That repopulated archive was not properly repopulated and emails disappeared). This was nothing to do with Eaglefiler; it was user error.
Thank you very much for all the help; I really appreciate it!