C-Command Software Forum

EagleFiler not responding during file import

Hi,
first of all I think EagleFiler is a great app but I have some problems with importing files. I simply draged a whole folder with about 70000 files (mainly pdf, jpg and txt) and a total of 10 GB onto my EF-Library for indexing multiple times but then EF is not responding any more but still seems to do something (3.5-4.5 % CPU in Activity Monitor). There is no eftexttool or efindextool process running. Is it possible that EF becomes active again after some time (longest time I waited were 4 hours) or is the only way to get it working splitting files up into small portions (time consuming)? Btw I’m working under 10.5.1 PPC.

Thanks in advance
sherlokk2

sherlokk2,

EF is designed to handle pretty large files and data.

What happens if you first open the Activity Window (Task bar: Window > Activity Viewer) ?

My guess is that you’ll see one or more progress bars indicating that EF is actually busy importing, saving metadata (at launch) and/or indexing your records.

Unless you see nothing in that window as/after you drag such large (numbers of) files to be imported, I don’t think you’ve anything to worry about.

Michael will correct me if I’m wrong here - and good luck :slight_smile:

What do you mean by “multiple times”? Are you saying that you were importing multiple large folders simultaneously? Or that you tried the same import several times in sequence (with the same library?) and the same thing happened each time?

It would be helpful if you could open the Activity Monitor program and select EagleFiler in the list. When it stops responding, choose Sample Process from the View menu. Then save the resulting data to a file and e-mail it to me.

If EagleFiler’s Activity Viewer doesn’t change in that time, then it’s probably stuck. I’m not sure whether that would be caused by the number of files or the specific files being imported, since I don’t recall seeing this sort of hang with EagleFiler 1.2.7. Hopefully the sample log will tell what’s happening.

Wow, thank you for the fast replies!

I deleted my Libraries, rebooted the System again, opened the EF Activity Window and couldn’t reproduce the freezing any more. It will still take a long time (eta 9 hours) to get all the files into the library but as I only have to do this once it is not a problem.

Right, I was trying it several times with the same result after some minutes.

Thanks for the great support, in case the problem occures again I know what to do,
sherlokk2

Yeah, I’m sorry about that. It can get slow for large numbers of files. Checking “Allow duplicates” in the preferences will speed it up some, and I’m working on some significant import optimizations for 1.3.

Checking “Allow duplicates” in the preferences will speed it up…

Is it possible, once a bunch of duplicates has been let in that way, to dedupe after the fact, Michael?

No (unless you want to write an AppleScript).

Thanks, Michael :slight_smile:

EagleFiler 1.3 fixes a bug that could cause an import to get stuck. Importing is also a bit faster now.

Great news; thanks Michael!