C-Command Software Forum

Eaglefiler won't launch on El capitan 10.11.1

Hello,

Eaglefiler was working Tuesday.
Now it won’t launch.
The App Store asked me to reinstall, but it didn’t change anything.
A colleague has the same issue with a different mac.
It seems that XPC kills Eaglefiler.

Edit:
I read on the web that some apps with an old embedded signature needs to get a new signature from the App Store… and sometimes it doesn’t work. There are some workarounds like disconnect and reconnect from Appstore, rebooting… But nothing worked for me…
Any idea ?

It seems to be an Apple bug that affects the whole App Store. Please see this page.

thank you.
I’ll use the trial while waiting apple to fix this

I did just that, and was working with the trial version when suddenly I got a popup error message saying the database could not be saved due to some error in sql lite.

Then all my files disappeared. Not just in the EagleFiler library, but from the hard drive as well.

I’ve lost all my files!

Help!!!

That probably a indicates an issue with your hard drive, separate from the App Store and EagleFiler. If the database is damaged but you still have your EagleFiler library folder, you can rebuild the database.

EagleFiler doesn’t touch documents outside its folder, so (especially combined with the database issue) this was probably caused by a more general system or hardware problem. I recommend first backing up what you can (without overwriting any previous backups) and then running some disk repair utilities.

Thank you very much for your prompt reply!

I ran the disk utility repair and got my files back.

I have been using EagleFiler for many years and my faith in your product and support has been restored. Thank you again!