C-Command Software Forum

errAEEventNotPermitted when using dropDMG from command line

Hi guys,

I’m using DropDMG to automate the creation of the disk images for my software. My build script has stopped working after upgrading to Mojave tonight.

I have the latest release (3.5.4), I have added DropDMG to the “Full Disk Access” and the “Automation/Finder” section and it works fine in interactive mode, but produces:

Error: The operation couldn’t be completed. (OSStatus error -1743.)

when used from the command line via “dropdmg my.app”.

I have tried to fix this by adding the command line tool to Full Disk Access, I have enabled the “always run as root” option and authenticated. I have made sure that the dropdmg command line tool is at the latest version.

The dropdmg command line tool does not ask for any permission and I don’t know how to add it to “Automation”.

Any help would be appreciated.

I think you want to add the app that’s running the tool to Full Disk Access and Automation, e.g. the Terminal app.

Hi Michael,

Yes, the problem was that I ran the build from iTerm which apparently does not yet support Mojave new Apple Event security model. I tried with Terminal.app and it asked straight away for access and then worked just fine.

Thanks for the great support. I really appreciate it.

Having similar trouble with -1743 but no way to add Automation permission
Hi, I also just updated to 10.14.5 and now trying to use DropDMG to package my signed app. I sent a support email but also figured I’d add a reply here.

I added DropDMG to Full Disk Access, but I can’t seem to find how to allow DropDMG for Automation. There is no option to add an app, and when I open DropDMG it does not ask me about permission, but reports after I drag-and-drop the .app file that the operation can’t complete, OSStatus error -1743.

Any ideas about how to proceed?

-jonathan

It sounds like you are not using the command-line tool (Xcode workaround for it here), so the situation is a bit different. But error -1743 is still errAEEventNotPermitted, which means that DropDMG needs Automation access, likely to control Finder. There is no way to add an app to Automation except by the system asking you. But what you can do is reset the system database as described under Troubleshooting Automation Access so that it will ask you the next time it needs access.

Hi Michael, you are impressive, answering on Sunday evening! Really appreciate the support.

I tried resetting the AppleEvents but still did not work. I then uninstalled DropDMG and then reinstalled it, poof, came up with the prompt and successfully created the DMG. Interestingly, even though I uninstalled DropDMG, it remembered all my settings so that was a bonus, I was expecting the uninstallation to remove all files. Again, I’m very grateful for your attention, you saved the day!

-jonathan

That’s great—thanks for the follow-up. It sounds like the application file was damaged. macOS won’t grant any security/privacy privileges if the app is damaged (because it has an invalid code signature).

That is expected unless you delete the DropDMG data when uninstalling.