C-Command Software Forum

error -25293 (DropDMG 3.4.5)

Getting the following error when trying to update/view a passphrase set for a given profile (in my case a dmg LZFSE with 256-bit AES).

Tried re-installing. Problem exists in the last 2 releases AFAIK.
Also tried to manually give DropDMG explicit rights in Privacy -> Accessibility… no luck.

The operation couldn’t be completed. (OSStatus error -25293.)

Same error appears in a workflow when sending a folder to DromDMG.

Error Domain: NSOSStatusErrorDomain
Error Code: -25293
MJTCodeString: SecKeychainFindGenericPassword(_keychain, (UInt32)strlen(service8), service8, (UInt32)strlen(account8), account8, &passwordLength, &passwordData, NULL)
MJTFile: /Users/mjt/Documents/Programming/MJTFoundation/Source/MJTKeychain.m
MJTFunction: -[MJTKeychain passwordForService:account:error:]
MJTLine: 152
Error Stack Frames: (
    "-[DropController enqueueBulkJobsWithSourceURLs:temporaryOptions:] (96)",
    "-[DropController enqueueBulkJobWithSourceURLs:convert:temporaryOptions:configFile:error:] (244)",
    "-[MJTKeychain passwordStringForService:account:error:] (178)",
    "-[MJTKeychain passwordForService:account:error:] (154)"
)

That error number corresponds to errKCAuthFailed. What happens before that error? Does it ask you to unlock your keychain? Did you deny access in the past?

This is a keychain error. It has nothing to do with the Accessibility privileges. You might be able to address it using Keychain Access.

Don’t think I did. Where can I check/verify that?

p.s.

it’s Security & Privacy -> Accessibility -> Privacy where I was looking…

Keychain Access is an app in the Applications/Utilities folder. For any given password, you can control which apps have access to it. But it’t normally not necessary to go into Keychain Access at all if you enter the right keychain password when DropDMG prompts you to unlock it.

DropDMG does not use the Accessibility stuff at all.

Great. Seems to work when I don’t have a passphrase set for the profile .i.e. provide it manually. If I have password set in the profile, I get this message every time I try to archive or even edit the password.

I’ve deleted all DropDMG related passwords from the Keychain Access and then created a new profile. The error appears immediately after setting a password and then clicking again on “Set Passphrase” to try and edit it.

I assume that by “profile” you are referring to a DropDMG configuration. It is normal when you set a passphrase for DropDMG to try to save it to the keychain. Do you get any kind of system dialog asking whether you want to give DropDMG keychain access? Or does it immediately fail with the error?

It might help to use Keychain Access to “Reset My Default Keychain” and then copy over the items from your old keychain.

No error messages at all when setting the passphrase. Only after, when trying to change, or indeed when trying to create an archive.

Have you tried resetting the keychain?

Hi Michael, I’m having the same exact error. I tried all I could think of, including your suggestion of resetting the keychain. Is there anything else I could try?

Which versions of DropDMG and macOS are you using? Does the error occur after resetting the keychain but before copying your old items to the new keychain?