C-Command Software Forum

Error -5000?

I have been using DropDMG for a particular project for several versions now. Today was the first time I tried to use 3.0.4 with this project. When I drag my source file onto DropDMG it begins to create the disk image as usual, but then fails with the following message:

Error The operation couldn’t be completed. (OSStatus error -5000.)

How do I go about fixing this?

Thanks!

– Kimball

That error means:

afpAccessDenied: Insufficient access privileges for operation

Is either your source or destination folder on a network server? Also, it might help to check the Always run with root access option in the preferences.

Hi,

I have the same situation here, I have checked “Always run with root access” and even restarted mac thinking it might help.

Thanks for your help,

Jean

Is either your source or destination folder on a network server? Are you using FileVault? Where do you have the DropDMG application installed?

hi,

Got it to work, I actually had to NOT check “Always run with root access” then all went fine. I did some reading on your forums and help and straight away checked that box…

Not running over any network or weird setup, and dropDMG within the applications folder.

Bye,

Jean

I got it to work by UN-checking “Always run with root access” - though I have not tested the resulting image on other macs, it appears to have been created correctly on my mac.

Here is a possibly useful dump from the system console when I run it WITH root access:

12/14/10 12:24:38 AM DropDMG[7592] Error: <CreateJob: Creating from “Auriculo PC”> <NSError Domain=NSOSStatusErrorDomain Code=-5000 UserInfo={
MJTCodeString = “FSSetVolumeInfo(info.volume, kFSVolInfoFinderInfo, &volInfo)”;
MJTFile = “/Users/mjt/Documents/Programming/DropDMG/Source/Hdiutil.m”;
MJTFunction = “-[Hdiutil makeVolumeAutoOpen:error:]”;
MJTLine = 1038;
MJTStackFrames = (
“-[Hdiutil applyLayoutOptions:toVolume:error:] (1013)”,
“-[Hdiutil makeVolumeAutoOpen:error:] (1042)”
);
NSFilePath = “/Volumes/Auriculo PC”;
NSLocalizedDescription = “The operation couldn\U2019t be completed. (OSStatus error -5000.)”;
}>

Thanks for the additional information. I’m not entirely sure why creating the image with root access causes the problem, but I believe I’ve worked around it. Please contact me via e-mail to get a pre-release build of DropDMG.

This is fixed in DropDMG 3.0.6.