C-Command Software Forum

Error: Could not import URL

I have tried to create a web archive using both Firefox and Safari and the same thing happens each time; I get an error message stating the Eaglefiler couldn’t import the url. How do I resolve this issue? What am I doing/configuring wrong?

Wayne

It would help if you could tell me the URL that you’re trying to import and the exact text of the error message.

RE: Can’t import URL
I tried it with Google, Digg and a couple of others, it just wouldn’t work. I even tried to web archive the page I’m presently on and I get the same error.

Sorry, I forgot the text of the error message in my previous post:

Could not import URL
(the address of the web site) ie: http://www.google.ca/

This happens every time I try to capture a web archive using F1.

Wayne

Those sites should definitely be working. There should be more error information in the bottom part of the Errors window after you click on the error. Also, it would help if you could e-mail me EagleFiler’s log file:

/Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

Hi, I’m giving eaglefiler a try and was wondering if there is a resolution to this? I’m having the exact same error with Safari and Firefox.

Additional info is: Please check that the URL is valid and that the server is accessible and does not require authentication. [can’t connect to host]

Relevant portion from log:
2010-01-16 02:32:54,298 - jobs.pyc:538 error: <AddURLJob 0x17d5fd78> CouldNotImportURLError: CouldNotImportURLError
2010-01-16 02:35:15,038 - appcontroller.pyc:161 Launched EagleFiler 1.4.12 (on Mac OS X 10.5.8) at 2010-01-16 02:35:15 +0200
2010-01-16 02:35:23,581 - jobs.pyc:1922 Error Domain=NSURLErrorDomain Code=-1004 UserInfo=0x1bd149d0 “can’t connect to host” URL: http://c-command.com/forums/newreply.php?do=newreply&noquote=1&p=8390
2010-01-16 02:35:23,582 - jobs.pyc:1926 userInfo: {
NSErrorFailingURLStringKey = “http://c-command.com/forums/newreply.php?do=newreply&noquote=1&p=8390”;
NSLocalizedDescription = “can\U2019t connect to host”;
}
2010-01-16 02:35:24,074 - jobs.pyc:538 error: <AddURLJob 0x17d5fd78> CouldNotImportURLError: CouldNotImportURLError

I was using little snitch but disabled it and still no joy.

Thanks for any help!

Oh sorry, seems I’ve failed to set my littlesnitch rules right.

Thanks for the follow-up. This seems to be a common problem, so I will add a note to the error message to check Little Snitch.

Recently, when I tried to import some blog page as webarchive, EagleFiler Could Not Import URL.

  1. In Errors panel, the following message also appears:

Please check that the URL is valid, that your Internet connection is working, and that you are not blocking EagleFiler using Little Snitch. [can’t connect host]

  1. In EagleFiler.log, I found the following;

2010-05-24 00:45:09,648 - jobs.pyc:1923 Error Domain=NSURLErrorDomain Code=-1004 UserInfo=0x17af01a0 “can’t connect to host” URL: http://bunzaemon.jugem.jp/?eid=11106
2010-05-24 00:45:09,649 - jobs.pyc:1927 userInfo: {
NSErrorFailingURLStringKey = “http://bunzaemon.jugem.jp/?eid=11106”;
NSLocalizedDescription = “can\U2019t connect to host”;
}
2010-05-24 00:45:10,160 - jobs.pyc:538 error: <AddURLJob 0x1c07f938> CouldNotImportURLError: CouldNotImportURLError

  1. When I tried to import it again (by force), I CAN import it without Error.

  2. Though I don’t install Little Snitch, I installed ClamXav and use it as ClamXav Sentry in the MenuBar. ClamXav has no message log about this issue.

I would appreciate any kind of suggestion about this.

regards,

This error generally means that there’s a problem with your Internet connection, the server is down, or that you’ve installed some sort of local firewall software (Little Snitch, NetBarrier, etc.) that’s blocking EagleFiler from making outbound connections.

What does “by force” mean, and how does it differ from what you were doing before?

As for anti virus software ClamXav, I will exchange iAntiVirus from it and will wait a little longer and see what happens.

“By force” means that I tried to import the SAME webarchive simply AGAIN. At that time, EagleFiler said NO error message and I could find this webarchive in Source List and also view it correctly via Record Viewer.

Thank you for kind reply as always.

By searching EagleFiler.log, I found the same error like:

2010-03-16 23:16:59,064 - jobs.pyc:1923 Error Domain=NSURLErrorDomain Code=-1004 UserInfo=0x1c023be0 “can’t connect to host” URL: https://bubbl.us/beta/
2010-03-16 23:16:59,065 - jobs.pyc:1927 userInfo: {
NSErrorFailingURLStringKey = “https://bubbl.us/beta/”;
NSLocalizedDescription = “can\U2019t connect to host”;
}
2010-03-16 23:16:59,340 - jobs.pyc:538 error: <AddURLJob 0x18915cf0> CouldNotImportURLError: CouldNotImportURLError

At that time, this error appeared six times and I could not import this webarchive at last. However, I CAN import it TODAY.

regards,

If you are doing the same thing in EagleFiler and sometimes it works and sometimes it doesn’t (and you haven’t changed any other software on your Mac), I think that points to a network problem (either your connection or the server). So this is probably not something that you can directly fix.

I also think you are right.

As this issue has happened for TWO urls (of around 6800 webarchives), this issue might be stochastic and depend upon day-by-day condition of my network.

Thank you so much for your kind advice again.