C-Command Software Forum

Error message Spamsieve.mailbundle not compatible w Mail 14

Had a bunch of problems with the Mac yesterday. Four hours chat with Apple Support. Everything cleaned up except now Spamsieve.mailbundle is being rejected, which was never a problem before.

Installed new SpamSieve 2.9.41. Didn’t change .mailbundle rejection.

At the same time Mail is also rejecting MsgFilter’s .mailbundle.

Feels like I should re-install Mail but I don’t know if that’s possible.

There’s a bug in Mail where it will report “Incompatible Plug-ins Disabled” even when the plug-in is compatible if there’s damage to the folder where Mail stores the plug-ins. To get SpamSieve (and MsgFiler) to load, you can reset Mail’s private plug-ins folder.

Alternatively, a clean install of macOS (i.e. erasing your Mac, installing macOS, then restoring from Time Machine) will also fix the problem.

Followed that instruction to the letter (SIP off/one etc.) and still got the .mailbundles shoved away.

Don’t have the time to go through the clean install and restore. Yuck.

Thanks for the suggestion, though.

That’s strange, as I’ve never seen that remedy not work. Please update to SpamSieve 2.9.42b3 and then use the Save Diagnostic Report command in the Help menu and send me the report file, as described here, and I’ll take a closer look. You could also try enabling the plug-in with SIP off and see whether that makes a difference.

Enabling the plug-in before reasserting SIP might work. I’ll try when I have the time. Thanks.