C-Command Software Forum

Errors in 'convert for editing'

Michael,

I just tried to convert a .webarchive for editing (i.e. to .rftd). But EF borked, claiming that the rtfd is already in the library. A check in the errors window reveals that it was not in the ‘Files’ directory but in a numbered sub-directory of an internal directory in the EF package (EagleFiler-M5c1SQ in my case).

So I deleted the sub-directory of the internal directory and restarted EF. It complained that the .rtfd file was ‘missing’. OK. So I tried coverting the original again.

Now EF complains both that the file is duplicated AND missing.

http://www.inquit.com/images/EF-ErrorWindow.jpg

Rather than get myself further into trouble, I thought I’d ask for advice.

Peter

You should click the Reveal In Library button to see which folder EagleFiler thinks it’s in. In any case, to prevent this problem you could go to the preferences and tell EagleFiler to allow duplicates. I should probably change EagleFiler to not complain about duplicates when using Convert For Editing.

You don’t mean that the Errors window said that it was in the numbered folder, do you? Those numbered folders are temporary folders, which are not considered part of the library, and there should be no reason for you to access them.

If it says a file is missing you should either find the file within EagleFiler, delete it, and empty the trash; or else use the Finder to copy the file into the location where EagleFiler expects it.

That’s exactly what I did

Yes, I do. When I pressed the ‘reveal in finder’ button in the ERRORS window it showed me the file in the Temporary folder inside the .eflibrary file.

I guess I’m not explaining this very well, Michael. The same file that it says is ‘missing’ it ALSO claims is a ‘duplicate’. But the ONLY instance of this file is NOT in the standard file-tree for the EF library, it’s in the temporary folder inside the .eflibrary file.

Please see the image attached to my message. I still haven’t been able to unwind this error. It’s not debilitating, only annoying. I’ve created an RTFD for myself outside of EF so I can get on with things because I can’t get EF to ‘convert’ this file at all.

Peter

Reveal In Finder shows the file that was not imported because it was a duplicate. The Reveal In Library button shows the copy that’s already in the library. So what you describe seems normal to me.

Right, because the one in the library is missing. As I said above, you have two options:

  1. Use Reveal In Library to find the missing file within EagleFiler, delete it, and empty the trash. Then import the copy that you have. It will no longer be considered a duplicate.
  2. Copy the file that you have into the folder (inside the Files folder) where EagleFiler expects the missing file to be. Then it will no longer be missing.

Did you try either of these?