C-Command Software Forum

F1 doesn't work

I highlighted an email in Mail, did the F1 (and F1 + fn) with no capture results. (F1 dims the light and F1+fn brings up Spotlight.) I’m using an iBook G4 (OS 10.4.10). What am I missing?

If you already have F1 set to bring up Spotlight, try setting a different key in EagleFiler’s preferences.

Setting capture key
Tried to reset the capture key but somehow messed it up. I first tried F7 and clicked “set” but then it showed “A” instead. So I then "Clear"ed it, but now nothing I try (F7, opt+a) gets inserted into the Preference dialog box for the capture key. It just stays blank.

Did it show “A” in the sheet, or in the Preferences window after you dismissed the sheet?

Do they appear correctly in the sheet before you click Set? Do you have any keyboard shortcut utilities installed that might be interfering here?

Capture key screen
My memory is hazy, but I believe it showed “A” in the sheet and it might have continued to the Preferences window after I clicked on “set”.

The problem now is that nothing is showing up in the sheet regardless of which keys I type. I’ve never set up any shortcut keys. The only ones I’m aware of are the preset apple one’s plus cmd-space for Launchbar.

Have you tried restarting your Mac?

But you said that you set F1 for Spotlight, right? That’s not how Apple preset it.

capture problem
I restarted my Mac with no changes.

On Spotlight, it’s F1+fn that brings it up. F1 just dims the screen. I didn’t set either of those.

Problems
Deleted EgleFiler. Reinstlled. Tried to set F7 in cpture screen. When returning to preferences see A. As you cn see, now it’s smll cp A tht hs become the function key.

When you install Mac OS X, the default key for Spotlight is Command-Space. So if it’s now F1, you (or some software that you installed) must have changed it.

When EagleFiler and other Mac OS X software refer to keyboard shortcuts, they never mention fn. The fn key is not part of the shortcut. It’s simply an extra key that you need to hold down if you have the Keyboard preferences set so that the F1–F12 keys control hardware features such as brightness and sound.

Did it show F7 or A in the sheet? Have you tried other keys such as F11?

There was no attached screenshot, so I can’t see. I don’t know what “smll cp A” means.

Please try going to the Accounts pane of System Preferences and creating a new Mac OS X user account. If you log into that account and install EagleFiler there, F1 should work. Does it? Are you able to change the capture key to something else?

Screen capture
“smll cp A” = “small cap A”. It seems that anytime I use a function key to become the capture key, it translates it into “a”. So every word I was typing with “a” caused EagleFiler to file a document but wouldn’t let me type with the letter “a.” But it was showing “A” in the screen.

Anyway, I have finally been able to set “F7+fn” as the capture key. I’m not sure why I couldn’t earlier, although there was a small difference is clicking on “fn” first, hold, and then click on “F7” instead of clicking on both at the same time. I used it on a webpage and it worked.

However, when using it in “Mail”, I get the following message,

"The capture script for Mail reported an error:

EagleFiler cannot capture from the mailbox “Inbox”.

If this is a special “merged” mailbox such as Inbox, Sent, or Trash, please try capturing from one of its submailboxes, or move the messages into a regular mailbox and then capture that. (If you only have one account, create a second, empty account and then you’ll be able to expand the merged mailbox to see its submailboxes.)

If this is an IMAP mailbox and you have an IMAP path prefix set in the Advanced tab of Mail’s Account preferences, then EagleFiler will not be able to capture from this mailbox, but you can import it via drag and drop."

So, I am able to do it in a submailbox, but I’m not able to import via drag and drop. When I drag the email to the drop box, it just bounces back. It works with other files and URLs but not emails in Mail.

If you have the Keyboard preferences set to require the fn key, you always need to hold the fn key while you press the F1–F12 key. That’s just the way it works. If you press them “at the same time,” the OS may register the F1–F12 separately and adjust the brightness or volume, etc.

That’s the expected behavior. The way Mail is coded, individual messages can only be dragged within Mail. You can, however, drag and drop mailboxes.

F1 key
Thanks for the help and patience.

EagleFiler 1.4.5 improves the capture process so that you should now be able to import any message from Apple Mail by pressing the capture key.