C-Command Software Forum

F1 works only after repeated tries

I’m using Leopard and a new Mac with the function keys mapped to hardware functions. So, in EF, I know I have to press fn before F1 to add a item.

Adding things from Mail takes two or three presses. Adding web pages from Firefox takes up to 10 tries.

I’ve experimented with long presses, short presses, long press on fn before pressing F1, etc. No clear favorite. I just repeat till I hear the sound and see the action in the Activity Viewer. I’ve also checked that nothing else has F1 assigned to it.

Using Drop Pad works on the first try, but it’s easier to press a key. And, since I’m using Spaces, Drop Pad is not always visible.

This happens with EF 1.2.7b3, but was the same with EF 1.2.6.

EF 1.2.6 with Tiger on an old G4 responds every time to one simple press on F1, so it seems to be either the new Apple keyboard model or Leopard.


Thanks for the report. It might be due to a bug in the OS, but I haven’t heard of anyone else having this problem with Leopard. Do you have any other drivers installed? Are you using version 1.2 of the keyboard software? Have you tried switching EagleFiler to a different key (maybe a non-function key, or F5, which doesn’t have a hardware function) to see if that works better?

I’m considering making the Drop Pad visible on all the spaces. What do you think?

The Keyboard driver (AppleHIDKeyboard) seems to be version 1.0.5, but when I try to apply the software update package KeyboardSoftwareUpdate1.2, I get a message saying that the one already installed is newer.

If I set the capture key to F5, it works on the first try. And if I set the system preference to “Use all F1, F2, etc. keys as standard function keys” F1 then works correctly again.

I then tried to set it to F3. Same behaviour as with F1. If the hardware keys are enabled directly, using fn+F3 works only after repeated tries. If I check the “Use all F1, F2, etc. keys as standard function keys”, F3 works immediately.

It may interest you to know that I also use WebNoteHappy and the exact same thing happens when I set the shortcut to F2. However, I then played with it for a while and could not get a consistently repeatable behaviour. Sometimes fn + function key works on the first try, and repeatedly so, sometimes it gets stuck and stops working, or calls for many tries, and with EF I get the same erratic behaviour. One thing is sure, if the shortcut is on a key that doesn’t call for the use of the fn modifier, then all is well.

My guess is a bug in the OS.

My personal solution: use F16 (new placement on this keyboard, above the keypad, at the start of a row with the new F17, F18 and f19.)

Good idea, but only as an option that can be activated or not in the prefs.


Nooo… please don’t Michael. I find the requirement to have EF as an active window in order to capture a document or part of a text is the least attractive part of the interface. I HIDE EF (cmd+h) when it starts up and, except when browsing the library, keep it hidden (including the drop pad).

I would much rather you made EF work (with a default library selection) while NOT active: (or not even started, using a demon?).

Personally, I hate having any utility visible all the time … Even on my 23-inch monitor, desk space is at a premium. Having a couple of Adobe apps running plus a browser and the finder and there’s a virtual desktop that looks as bad as my real one. Spaces is a way to recover some sanity and clarity. Please don’t let EF put itself in every one.

Thank you.


Of course.

I don’t really understand what this has to do with making the Drop Pad visible on all spaces. If you don’t want the Drop Pad visible to begin with, why not just close it?

I understand your desire not to see the window(s), but given that it’s so easy to hide the entire EagleFiler application (or stick it on a different space), and that it’s potentially confusing to have a library open/selected but invisible, I’m currently planning to keep things the way they are.

drop pad and Spaces
Spaces has just been significantly enhanced with the “shift to a Space with open windows when shifting to an application” choice." (The enhancement is that you can turn this OFF, as I understand it - but I’m new to 10.5)

What is the best way to drop material into EF from a different Space? There are about 7 ways to get material into EF - which of them will work when EF is not open in the current Space? Specifically, I want to drag and drop, even when I am in a Space where EF is not open. I’m nervous about unexpected results with some methods of importing.

Personally, I think keeping the drop pad activated in all Spaces would be great. The pad can be made quite small, and I’m often using 2 monitors anyway so real estate is not a problem.


Probably to drop onto the Dock icon, since the Dock appears in all spaces. Of course, you can also switch spaces in mid-drag, e.g. by dragging off the edge of the screen or by pressing the “activate Spaces” hotkey during the drag.

I’m not really sure what you mean. Why would it matter which space EagleFiler is in?