C-Command Software Forum

folder copy bug

This is a bug that’ll make your toes curl…

I’m importing some files from finder into eaglefiler. I’m using EF 1.4.9 and I’m dragging the files from a folder in finder into a specific folder in EF. If any of the folders that I’m dragging across are exploded in the original finder window, then the contained files get copied into the target folder directly AS WELL AS the child folder in EF. Thus you end up with 2 copies of the file, in the parent and also the child folder. If you have a series of nested folders in the original (and they are exploded when you drag and drop) you can end up with many more than 2 copies of the original files in EF.

It’s easily worked around (don’t drag and drop exploded folders) but thought you should know.

Nic Mapstone

To clarify: it doesn’t matter whether the folders are expanded in the Finder; what matters is whether you have selected both a file and its containing folder before dragging. I’m not sure this is really a bug, since it’s the way drag and drop on the Mac has traditionally worked. For example, the same thing will happen if you drag and drop to attach the folder and files to a Mail message. However, it’s on my list of things to polish.

OK - I’m prepared to accept it isn’t a bug - but to the uninitiated it sure looks like one!

I did try out the same thing just copying from one folder to another in finder - to see if it was peculiar to EF or was a Mac trait - and it didn’t seem to do the same thing - so I assumed it was unintended.

I was surprised to see that. As I recall, the Finder used to behave the way EagleFiler does now.

just tried it in Finder, Snow Leopard, dragged and dropped the contents of a folder to another window - the folder contained files and a nested folder, which was exploded, and everything was selected - I just got one copy of everything in the target.