C-Command Software Forum

Font change on import

I’m using 1.4.6. I’ve imported a bunch of records from Yojimbo. Most were unchanged but some, essentially those that I’d pasted into Yojimbo using its Quick Input Panel, suffered a font change from Helvetica to Monaco. That wasn’t a particular problem except that I couldn’t change the font of those records back to Helvetica in EagleFiler by highlighting and selecting the font in the font panel. The solution that I found was to paste the text into Nisus Writer, convert it to Helvetica and drop it into a new RTF record in EagleFiler. There must be an easier way so I must be I missing something in the manual (I did look) but what?

EagleFiler and Yojimbo (and TextEdit, for that matter) support two types of text documents: plain text (.txt) and rich text (.rtf). In EagleFiler and the Finder, these have different icons. Yojimbo displays them using the same icon, but it knows which items have no formatting and exports them as plain text.

By definition, plain text documents cannot have individualized formatting, so EagleFiler’s Format commands are inoperative for them. Instead, plain text files are displayed using the font chosen in the preferences. You can change the font there and affect all your plain text files at once.

Thanks for the clarification. I had thought that the formatting established in Yojimbo on import, would ‘stick’ on export. Clearly a bad thought!

It will, if you establish the formatting in Yojimbo for that specific item. In this case, it appears that you imported it into Yojimbo as plain text, so Yojimbo and EagleFiler kept it that way.

OK - if I understand you correctly, text selected and copied from, say, the middle of a web page, will not ‘carry’ any formatting. When that text is pasted into EagleFiler or Yojimbo, it will ‘adopt’ the formatting set in the respective preferences (in my case Yojimbo uses Helvetica 12 as its default note font while EagleFiler is currently set to Monaco 9). But that formatting does not ‘stick’ when it is moved on. To format such text, it has to be written in EagleFiler, Yojimbo etc. or copied from a ‘formatted’ source (Nisus Writer in my case). Correct?

While I can understand this behaviour with text, it seems slightly inconsistent that weblocs transfer formatted. But we’re drifting a bit off-topic here. Thanks for your help.

If you use Safari or another WebKit-based browser, copied text will carry formatting. The formatting will also be preserved if you import via the Services menu or the capture key. I think Firefox only supports plain text.

I don’t know specifically why your text ended up plain in Yojimbo. From what I can see, it seems to preserve the formatting when you paste text in.

In EagleFiler, basically anything you do will make the formatting stick except if you specifically create a plain text file.

I’m not sure what you mean, as webloc files don’t have any content or formatting. They just hold Web addresses.

I generally use Firefox, keeping Safari for financial stuff only, so that explains why it got to Yojibo unformatted - thanks for the clarification.

Coming from Firefox, it just displayed with the font nominated in the preferences. And this font was not ‘carried over’ when it transferred to EagleFiler.

I use a ‘Bookmark in Yojimbo’ button which is similar to the ‘Bookmark in EagleFiler’ one. When I import the resulting weblocs into EagleFiler, their titles are formatted with the Yojimbo preference (Helvetica 12), from this thread I would have expected the EagleFiler preference (Monaco 9). I am just remarking it, I certainly didn’t want anyone to waste any sleep over it.

Right—since there’s no formatting, both Yojimbo and EagleFiler are displaying it using their default plain text fonts, which are not necessarily the same.

EagleFiler uses the plain text font for plain text files and plain text e-mails. This is because the plain text font is generally monospaced, and those are the types of records where it’s likely that the content depends on a monospaced font in order for things to line up.

There’s no need to display weblocs in a monospaced way, so EagleFiler uses the rich text font (Helvetica, by default). Still, weblocs have no intrinsic formatting, so their display will change if you adjust the rich text font in the preferences.