C-Command Software Forum

Fresh install Mojave B6 and v21.9.32b4 Plugin Permission does not show

I am running SpamSieve on my main system using B6 upgraded from the previous version and all is fine.

I just got a MacBook Pro with fresh install B6. But the Bundle allowance does not show. I manually installed it and gave the Accessibility Permissions to SpamSieve. I removed the bundle, restarted Mail, quit, put the bundle in place. Still no permissions or bundle loading.

Could you be more specific about what you are expecting to see and what you are seeing instead?

I would expect the Manage-Plugins button to show up in Prefs - nothing. So Spam Sieve will not load.

But it sounds like you ran into trouble before that step because you said that you manually installed it?

SpamSieve indicated it could not install the bundle, so I would have to do it manually.

Please check whether SpamSieve shows up checked under the Application Data list and (if so) ask it to install the plug-in again. If that doesn’t work, please tell me exactly what the error message says.

It did not show up there. I added it, deleted SpamSieve preferences and the Bundle folder in ~/Library/Mail and started the process over.
This time it worked.

BTW, so you know how to enable an app to send AppleEvents under Mojave? I have an app that is not triggering the permission request and thus cannot send events.

Great!

Unfortunately, I don’t think there’s a way to manually add apps to Security & Privacy ‣ Privacy ‣ Automation, as you can for Application Data. You have to rely on the system prompting you when the app first tries to send an Apple event. However, sometimes the system gets confused, and you can get it to ask again by resetting the privileges using this Terminal command:

tccutil reset AppleEvents