C-Command Software Forum

Get rid of my copy of Reply All

I’m in a SpamSieve trial.

I’m using Mac Mail. When I send a Reply All, I don’t want my copy of the e-mail coming back to me, as I know what I’ve just said. I used to have a Mac Mail rule to take those and tuck them away and mark them as Read.

Since installing SpamSieve, the copies ALWAYS wind up Unread in my Trash folder. I’ve played with all kinds of Mail rules, I’ve disabled them all, I’ve marked these e-mails as Spam with SpamSieve, I’ve manually entered rules for them in the Block filter.

Nothing makes any difference at all? Ideas?

In my experience, Reply All does not send me a copy of the message. Do you perhaps have “Automatically Cc: myself” checked in Mail’s preferences?

You can still use such a rule. If you want all messages from yourself to be processed in that way, just put the rule above the SpamSieve rule.

With the normal setup, SpamSieve doesn’t put any messages in the trash.

The messages are not spam, so you should not train them as such or add rules for them to the blocklist.

In my experience, Reply All does not send me a copy of the message. Do you perhaps have “Automatically Cc: myself” checked in Mail’s preferences?

Nope, and it’s always behaved this way. Wonder why my Mail program has always done this…

You can still use such a rule. If you want all messages from yourself to be processed in that way, just put the rule above the SpamSieve rule.

That’s what I figured. But no matter how I write that rule, they still go to the Trash as Unread.

But now it appears to be a Mac Mail issue rather than SpamSieve. I disabled the basic SS rule and it’s still happening. Very odd, though, that everything was fine until I installed SS.

And while I agree it seems odd to train SS to treat messages sent by me and to me as spam, it seems also odd that SS refuses to learn that.

Is the address of yours that it’s sending to different from the address you are sending from?

Then you should check your other Mail rules to see which one is moving the messages to the trash.

Before concluding that SpamSieve has refused to learn, you should check the log to see whether it is even processing the messages in question. For example, if the messages are going to the trash before Mail gets to the SpamSieve rule, SpamSieve won’t see those messages.

Yes. It turned out that was the problem. My company’s Exchange server turns all incoming e-mail to me into a username@xxx.xxx.xxx format, but the e-mail the server automatically (auto-discover) gives me when I set up the account is username@xxx.xxx.

I deleted the account and added it back and manually made the addresses match, and Mail no longer includes me in the Reply All. No need for a rule. I’ll never know why the rule I did have (using contains instead of is equal to) stopped working once I installed SS, but now I have the luxury of not caring.

Thanks!