C-Command Software Forum

Get rid of "Pharmacy" Subject Spam

I use SpamSieve to send redirect my spam to various folders based on color. For blue messages (scores 99 to 100) and gray messages (scores 95 to 98) I have rules that move the messages to Trash and then Delete the messages. The messages with lower scores go to various Spam folders by score where they are flagged. By and large this works well but over and over again I get Spam with “Pharmacy” as the Subject that gets a score less than 95 so it it just flagged in the Spam folders. Is there something I can do to force these emails to be scored higher than 94 so they will be moved to the high score Spam folders and deleted?

I don’t think there’s a good way to change the scores in the way you want. However, you could create a rule called “SpamSieve [Spam] Pharmacy” that looks for “Pharmacy” in the subject. This will only match messages that SpamSieve thought were spam, not all messages with “Pharmacy” in the subject.

I’ll try that, thanks.

The original poster did not have SpamSieve classifying the messages as good. It was marking them as spam, just not with as high a spamminess score as he wanted.

If you have spam messages getting through, I suggest sending me a report with the requested information. Then I will be able to offer advice for your specific situation.

Thanks, Michael – will do.

The “Pharmacy” rule doesn’t seem to be working. Here’s what I have
Rules_and_All_Mail_—Personal_Gmail__47833_messages__4_unread-2.jpg

Rules_and_Reply_to_thread__Get_rid_of__Pharmacy__Subject_Spam__—_All_Mail.jpg

and yet in my MAC mail V6.5 I see this

All_Mail_—Personal_Gmail__47833_messages__4_unread.jpg

Hmm, I’m not sure why. A similar rule is working on my Mac. Why are the messages in the screenshot not colored? Did you turn that feature off? None of the ]-style rules will work without coloring turned on. Or maybe the rules haven’t been applied to those messages yet?

In any case, I suggest for testing purposes that you change the action to only move the message, not delete it. Secondly, you can uncheck all the rules except the [Score] one, apply the rules, and make sure the message is colored as spam.

When I did as you suggested the message turned gray.

I didn’t mention this in my previous post but the 3rd image I posted is from my gmail ‘All Mail’ folder and I just found that it’s also in my ‘Trash’ folder but I don’t know if that happened before or after it turned gray.

Maybe in addition to saying “delete the message” I should also say Mark it as read".

Sounds like the rules may be working, then. The messages in the All Mail folder don’t have any interaction with SpamSieve, since Mail doesn’t apply the rules to them. In my opinion, All Mail isn’t very useful in Apple Mail. I recommend going into Gmail’s preferences and setting it not to “Show in IMAP”.

I’ve always wanted to do that since I agree that it’s useless but I’ve never been able to figure out how to do it. I know that this isn’t your job but can you help?

I found it in Settings|Labels - Thanks.