C-Command Software Forum

Getting Background Images to Stay with Folders

I have tried all variations of getting my background .jpg to stick with the .DMG when its distributed. I am saving the image on the .DMG (inside one of my folders - I could not the ".Background’ folder to save), setting View Options as desired, and on my Mac, it’ll ALWAYS appear.

However, when I then make a read only or read-write DMG from my first DMG, the image never appears, the icons sizes revert to a small size. What am I doing wrong?

It’s probably not your fault—sometimes the Finder doesn’t save the view changes to disk, so there’s nothing for DropDMG to copy when making the read-only DMG. It might help to create an empty folder on the image so that the Finder registers a change.

.Background folder no longer permissible on Leopard
Michael

I followed the advice given on the http://c-command.com/dropdmg/manual-ah/making-images-with-back but making a .Background folder is no longer permissible on Leopar. SO, I saved it to a lower-level folder on my read-write DMG and then created a read only of that DMG and on my Mac I view the image - when I send it to another Mac, the image and icon set doesn’t display.

Any ideas?

You would need to use a separate utility, e.g. Terminal, to create a folder whose name begins with a period. Or you could put the picture file at the top level and then make it invisible later. But this is unrelated to the original problem that you reported.

It’s working for me. When setting the picture, please make sure that you choose the picture file on the mounted disk image, not a copy of the file that’s on your hard disk.

Some Feedback and Documentation
I try .gif format as well as .jpg. I save the original .DMG WITH MY BACKGROUND image showing, and verify I have the image saved on the read/write volume I created, with View Options showing that background image. All loks God, except when I copy to another Mac, the image is gone.

So, I then create a ‘read only’ DMG of the original DMG using ‘convert’ from both DropDMG and Disk Utility. This keeps the resulting DMG large, but with READ ONLY, when I mount that volume on my Mac, the background image stays. When I transfer that second DMG to a different Mac, again, the image and icon views are back to normal and no image appears. I have tried saving the second DMG as a ‘compresssed’ (my preference as it reduces the size by ~ 100%) I get the same result. What can I possibly be doing wrong? I se background images on DMGs releases all the time, but I’m having a helluva time gettign one to work. Any advice anyone?

Please e-mail me the read-write .dmg (or a link where I can download it), and I’ll take a look.

I would not expect converting a broken .dmg to another format to make it unbroken. I suggest that you get it working with the original read-write image first.

DropDMG 3.0 includes some new features to make this much easier.