C-Command Software Forum

gif emails

I can’t get spamsieve to catch my latest and most annoying breed of spam, which is totally self-contained .gif files selling medicine. I get four or five every day. I use Entourage, and I am aware that Entourage has no easy solution for filtering messages containing gif files. Is there some way i can filter these using spamsieve?

SpamSieve should be catching those automatically. If not, please check for a setup problem or report the details of your setup to spamsieve@c-command.com so that I can investigate.

I just read another thread that suggested I set up this blocklist rule:

for any attachment / ending in / .gif.

So I did that. I’ll report back tomorrow whether it has worked or not. Anything else I can try to catch these gif spams?

In most cases where people report spams not being caught, the underlying cause is a setup or training problem. I think it’s best to fix this (see previous post) rather than to make a blocklist rule to try to cover over the real problem. That said, such a blocklist rule is a good idea if you know that you won’t receive legitimate e-mails containing GIF attachments.

Michael, can you offer me a usable explanation of what you mean here. I originally set up the program per the instructions in the online manual. You are now implying that i missed something essential. But you don’t tell me what it is I missed.

What I do know is that these annoying gif spams have not been getting filtered out by Spamsieve. Every time I have gotten one in the last week while using Spamsiece on trial, I have dutifully clicked the train spam script. But so far, after 10 or 12 tries, the gif spam simply doesn’t get filered out.

If there is a better way to handle the problem, besides making a new rule in the blocklist which blindly filters out ALL gifs, please tell me what it is, and specifically how to do it. Or at least tell me where I can find this info, because, as I say, I thought i had properly followed the set up instructions. Indulge me, because I don’t have the same level of knowledge either about spamsieve or email lingo as you do.

What I mean is that (a) it’s posible that Entourage is setup such that it is not asking SpamSieve to filter all of the incoming mail, or (b) a preference is set in a suboptimal way that causes SpamSieve to let certain messages through, or © that if SpamSieve were re-trained it would do better at catching the spams.

I’m not implying that you missed something, although that’s possible. It could be that you accidentally made a change after installing SpamSieve that caused the (a) problem above. Or there could be some other kind of problem.

I don’t know what (if anything) you missed. I would need to know more about your setup. To start with, please create a new message in Entourage to spamsieve@c-command.com and drag the SpamSieve log file into the message to attach it. This image shows where to find the SpamSieve log file in your home folder. After you send me the log, I will have a better idea about where the problem is.

Thanks for e-mailing the SpamSieve log file. It looks like (1) some of the messages that you’ve trained as spam were ones that SpamSieve had already predicted to be spam, and (2) others are ones that it had not been asked to filter.

A further problem is that SpamSieve has been trained with 234 good messages but only 126 spam messages. For best results, you should use about 65% spam messages in the initial training, however if you don’t have any more saved spam messages you can leave it as-is and the accuracy will improve as you receive more mail.

As to (1), have you been purposely training SpamSieve with messages that it already marked as spam and put in the Junk E-mail folder? This is not necessary.

As to (2), please choose Rules from Entourage’s Tools menu. Do you see one SpamSieve rule, or two? Do you see any rules above the SpamSieve rule(s)? Dragging the SpamSieve rule(s) to the top of the list can help ensure that Entourage applies SpamSieve to all of your messages. Also choose Mailing List Manager from Entourage’s Tools menu. Do you see any items listed there? If so, double-click each one and make sure that “Do not apply rules to list messages” in the Advanced tab is not checked.

thanks for your help Michael. there is one (not two) spamsieve rule about moving suspects to the email junk folder. My mailing list manager has one entry about news items. i never look at news.

so let me try it for a few days, and see if the gif files get filtered out. that was my only question. I am already quite happy by the number spam messages i see are getting filtered out.

SpamSieve will filter out the GIFs, but only if you make the necessary changes so that Entourage lets SpamSieve filter those messages. At minimum, you would need to uncheck “Do not apply rules to list messages” for the News rule in the Mailing List Manager.

Spamsieve is now catching my gif files. Bravo.

What I think you are saying here, is that using spamsieve trumps all my old rules for catching spam. I’ll try wqhat you say. I just deleted several rules I’ve established over the years, to let Spamsieve catch them in its own way. Thanks for your help.

That’s not what I was trying to say above, but it’s true. For a variety of reasons, it’s best to let SpamSieve catch the spam (either through its Bayesian classifier or through blocklist rules that you create) and to only use Entourage rules to process the good messages.