C-Command Software Forum

Gmail sent messages appearing in inbox.

Believe I followed the instructions for setting up a filter in gmail that included the option “Never send to spam” - and Spamsieve is working well. However I now find that every message I send immediately appears in my inbox. A bit of web searching suiggests this happens when a gmail filter includes the “Never send to spam” option. So unsure how to resolve this.

Anticipatory thanks…

dave

That shouldn’t happen if you set it up as shown here so that the filter excludes sent messages.

Well, pretty sure that’s what I have - here’s the screen shot.

Screen Shot 2016-12-16 at 8.29.19 AM.png

That looks correct to me. I’m sorry, but I don’t know any other way to do this with Gmail. Perhaps their support can help figure out why your filter isn’t doing what it should. The other option would be to leave Gmail’s spam filter on and then follow one of the options here.

Appreciate your help, Michael. I’ll give it a try.

This is now happening to me. This had not happened for the few weeks since I set up SpamSieve. It is clearly the filter as it does not happen when I delete the filter and recurs when I reapply the filter. Is the filter Doesn’t have label:sent supposed to prevent this? Not clear why it happens at all.

Gmail bug?
I’m having the exact same problem. Is it an Gmail bug and is there any solution available?

I’ve not heard of any recent problems like this with the correct filter. Please post a screenshot of what your Gmail filter looks like.

Here are two screenshots; I set the filter according to your manual.

Bildschirmfoto 2017-04-18 um 09.27.26.png

Bildschirmfoto 2017-04-18 um 09.27.12.png

Just to let you know: the filter worked fine for me for two weeks or so. Somehow the filter is broken for the last couple of days and I didn’t change any settings.

The filter looks good to me. I would suggest contacting Gmail, as it sounds like something changed there.

snipaste20170419_135909.png

So… I contacted Gmail yesterday. You can follow the conversation here. It’s in German but I think you’ll get the point.

Long story short: Google alleged that it’s not possible to turn off Gmails spam filter. The filter I set (according to your manual) is more or less wrong. According to Google it’s not possible to exclude labels in filters. The “label:sent” actually represents a hit list of the search query “from:me” and is not a label by itself.

So I’m totally confused now :frowning:

For now I’m using an “is:spam” filter that is shown in the attached screenshot.

Thanks for the follow-up. That is interesting, as “label:sent” seems to work for most people. Does “is:spam” (which is what I used to recommend) cause any of your sent mail to go to the Spam mailbox?

Nope. All my sent emails are just in the sent-Mailbox (as it should be) and all the spammy mails are in my inbox. So SpamSieve is able to do the job :slight_smile:

But I’m still in (filter-)test-mode to see what will happen in a long term with the “is:spam” setting.

After some days of testing I can approve that the “is:spam” filter works like a charm :slight_smile:

As you can imagine: I wrote an article (in German) about it.

I’m glad to hear that. Thanks for writing the article.

If the suggestion in the manual (“Doesn’t have” “label:sent”) doesn’t work, you can also try this one (From “@ AND -<your address>”).

is:spam Gmail filter

Thank you very much for this! What I had to muddle through your translated article for was the info that the label:sent criteria doesn’t get changed in the same DOESN’T HAVE: box, the new is:spam criteria goes in the HAS THE WORDS: box directly above. So thank you for solving my problem! For those who are as confused as I was I’m attaching a screenshot of your is:spam filter properly configured and working in my English Gmail settings.

Screen Shot 2017-09-15 at 3.05.33 PM.png