C-Command Software Forum

Gmail spam going to server spam folder, unread, and gmail all mail

I am a longtime user of Mac, SpamSieve, and gmail. I have set up my ‘always on’ MacMini with SpamSieve and followed “4.4 Setting Up a Spam Filtering Drone”. Apple Mail is client for 7 mail accounts, all IMAP, (2 iCloud, 3 gmail, 1 AT&T, 1 bluehost). Everything works great except my primary gmail.
I have set up that account per manual and “7.6.3 Turning Off the Gmail Spam Filter”
When a spam message goes to my gmail account I see it ‘briefly’ in the mail client on the MacMini, it then is routed to the “Spam” folder on the server. I review on the MacMini and delete. But it still shows up in the All Mail on the server side.
This may be normal, but I wanted to double check.

It sounds like you need to adjust your Gmail settings so that it deletes messages that are deleted on your Mac, instead of archiving them. You can do this by setting the When a message is marked as deleted and expunged from the last visible IMAP folder to Immediately delete the message forever.

My gmail is set up following “4.6.14 Keeping Spam Messages Out of Gmail’s Archive” (attached screenshot). I suspected something when several SpamSieve blocklist rules appeared not to be working.

That looks correct to me. Do you see the messages in the Archive mailbox on the Mac or other devices? Do you have the messages from all the accounts going to the same Spam mailbox?

I don’t think there’s any relation between the archive issue and the blocklist issue. For the blocklist, you can use the Open Log command to see whether SpamSieve classified those messages as good and, if so, why.

I meant to start off my last message telling you how impressed I have been over the years that user questions generally get a response quickly and from you! You must just live on the keyboard!

On my MacBook Pro (not the MacMini that runs SpamSieve) I see the same message in the Spam folder in the server and the Archive on my Mac (I just noticed that based on your comment).

I have set up gmail to never send to Spam.Screen Shot 2020-03-26 at 5.05.30 PM

My understanding of the “process” is mail comes to gmail and sent directly to Apple Mail (v13.4). once there SpamSieve on my MacMini sends straight to the Spam folder on gmail’s server (by rule).

I have remote training as my first rule, and SpamSieve gmail as my second rule (which I just realized has a lower case S in Sieve; which I will change).

I ‘reinstalled’ SpamSieve about 10 days ago to clean up my many tweeks over the last year or so. I figured I should start clean. Other than a dozen or so ‘corrections’, it, again, seems to work like magic! At this point (10 days later) the only things going to my Spam folder on gmail are in fact spam. I have not had to correct anything in several days.

Finally, the same Spam message referenced above was marked as spam by SpamSieve.

Thanks!

It’s unusual to have mailboxes inside the Archive mailbox. I wonder if something is messed up in that Mac’s Mailbox Behaviors settings so that the Archive is set to a mailbox other than All Mail?

Do you see an equivalent in Mail to the All Mail on the web that’s collecting the messages?

Right.

Is that rule for all three Gmail accounts or just one?

Here are my settings for that gmail account:


That could be part of it. When I set-up SpamSieve after re-installed a couple of weeks ago I used a Junk folder for gmail. Same thing was happening so I switched to the Spam folder for gmail. I checked the rule, the AppleScript, but not the Mailbox Behaviors.
I did not see anything like “All Mail”, just my TrainGood and TrainSpam folders.

My other two gmail accounts have their own rule, although they share a domain “muscogeelodge.org”.

Again - THANKS!

It’s possible that your Gmail settings have Show in IMAP unchecked for the All Mail mailbox. If you plan to keep that hidden from Mail (which is fine, as it prevents downloading duplicate messages that you likely don’t want to see), you could create a new Archive mailbox and select that in Mailbox Behaviors. Then your regular mailboxes would appear in the correct place in Mail.

OK, so just to confirm, each of the 3 Gmail accounts has a rule that moves the messages to its own spam mailbox. And you are seeing messages collect in All Mail for all 3 Gmail accounts?

You were correct (again)! My Show in IMAP was unchecked. I left it that way and created an ArchiveSpam mailbox (label).

Yes - each of the 3 gmail accounts has a rule that moves the messages to its own spam mailbox (screenshot). I ONLY see spam messages from my primary gmail in All Mail (stanhaines@gmail.com).

Just to confirm I understand the Train as Good & Train as Spam menu items:
If something is incorrectly put into any spam folder it is OK to use Train as Good; but do NOT use Train as Spam for those items.
If anything is incorrectly NOT put into any spam folder the it is OK to use Train as Spam; but do NOT use Train as Good for these items.

It sounds like you have everything set up correctly, so I’m not sure why you are seeing different results from that one account. It might help to experiment with choosing a different server mailbox or a local mailbox in that account’s rule. Or maybe this is simply a Gmail oddity that can’t be worked around.

That’s right. The basic idea is that you only need to correct SpamSieve when it made a mistake, not confirm that it did the right thing.

Just a quick follow-up FYI –
It appears I have reached a ‘detente’ with Google! My latest experiments have resulted in Spam messages sent to my main gmail account are sent to the Spam folder on the gmail server but NOT to the All Mail folder. I can live with that…
And they are being sent there by SpamSieve as I see them in the SpamSieve LOG.

Thanks AGAIN for you support!

Now I am not going to touch anything!

1 Like