C-Command Software Forum

Gremlins since upgrading to Sierra

Hi Michael,

I think I’ve got a consistent issue here since upgrading finally to Sierra just a few days ago. It’s very much related to this other thread I hopped aboard. But I think there might be more going on as well.

I’ve just confirmed that somewhere between quitting Mail.app and relaunching it, my two SpamSieve rules (for my two accounts) get disabled. At first it seemed to be a one-off thing, but it now seems to be regular. And in fact once in the course of today the rules somehow became disabled without any quit-relaunch.

There’s more as well. When the rules are enabled, I’m getting regular false negatives with spam messages from familiar sources which were correctly filed before the Sierra upgrade. I’ve tried re-doing the train spam, to no avail. I’ve also even added a blocklist thingy for messages where the “from:” contains a particular string that I see regularly. But the next message from that source also landed in my inbox.

This could be a permissions or iCloud problem. If you send in a diagnostic report, I can investigate further.

Likewise the report should show whether those messages are false negatives or whether Mail never sent them to SpamSieve for analysis.

Thanks for sending the report. It looks like there are lots of permissions problems. I think you can fix them by entering these commands in Terminal:

sudo chmod -RN "/Users/lance/Library/Mail"
sudo chmod -RN "/Users/lance/Library/Mobile Documents/com~apple~mail/Data/"

It will ask for your administrator password.

Also, it looks your SpamSieve rules in Mail are set up such that Mail is not sending SpamSieve most of the messages. You have it set to only let SpamSieve look at messages that Mail itself already thinks are junk. The only conditions in your SpamSieve rules should be “Every message” or “Account <account name>”.

Thanks very much, Michael.

OK, done that.

But the weirdness continues … For one, I’m now back to getting the request access to contacts on every launch.

Even weirder … On re-inspecting the conditions in in my rules, I found that somewhere in the upgrade process the “Account” condition in both account SpamSieve rules has been changed to <blank>. So I’ve gone to correct that - resulting in further weirdness. For one of the two rules (the second listed, in case it matters) the selection of the account from the menu has been successful. For the other (first listed) I select the relevant account - and behold when I check it again it’s been changed to the “iCloud” account (which I never use). So I change it again … and again … and… every time (presumably the moment I click ‘OK’?) it’s changed to ‘iCloud’.

While I’m on the subject of these rules - the conditions I’ve had for a very long time (and working perfectly until the OS upgrade) have been: 1. Account; 2. Every message; 3. Sender is not in my previous recipients. I can’t remember when and why I added the 3rd one, but as I say it hasn’t caused problems before. Should I delete it?

And lastly - shortly after my few minutes fighting with the rule settings, Mail.app crashed and then automatically relaunched. (I still have open the “Mail quit unexpectedly” report window).

I think the Gremlins are winning …

Please see Repeated Access Prompts.

I’ve never seen that before. Sounds like a Mail bug of some sort. If this is a criterion that you need to have, it might help to delete and re-add your accounts or to reset your accounts database by deleting the folder:

/Users/<username>/Library/Accounts/

You can keep it, but beware that it will prevent SpamSieve from filtering some of your messages.

Michael - I just had to leave this go for a few weeks (and limp along manually moving spam to the junk folder). Now a chance to get back to it. I had a go at deleting and re-adding the accounts. But it was a nightmare, and I ended up restoring what I had. With the way MacOS now does the internet account thing, I was getting messages saying I’d lose a horde of notes, calendars, etc - including in my iCloud account. That sounded all too scary to contemplate. Is there any other way to address the issue? Or any help file out there that would help a relative noob through the process of deleting and adding accounts? (How to do it without losing data I don’t want to lose, etc…)? I’m still getting the described behaviour - rule still defaults to “iCloud” as the account.

What did you do? What happened?

They should all come back when you re-add the iCloud account.

It might work to just uncheck the Mail account and leave the other iCloud items in place.

You could also try deleting and recreating the SpamSieve rules and temporarily uninstalling Mail Act-On.

Well it just got curiouser … But maybe I won’t complain. When I tried it out yesterday again, I left the rule enabled. And behold - SpamSieve now seems to be working as expected - even though the rule displays the mail account as “iCloud” and not the one it’s meant to be. So I don’t know … some cosmetic thing, but correct setting “underneath”??? Our’s not to reason why … Guess I’ll just monitor it and see if it keeps working.