C-Command Software Forum

hdiutil: create failed - Operation timed out

Hi!

I’m trying to archive a big (55 GB) Parallels VM that I no longer need. I’ve setup DropDMG v2.8.6 to create bzip2-compressed DMGs with segments no larger than 8151 for my DVD+R DLs. I was able to archive a smaller VM (8 GB) using these settings without a problem. However, I’m getting the error “Error 1 - hdiutil: create failed - Operation timed out” when I try to archive the big VM by dragging-and-dropping the VM folder onto DropDMG. The error doesn’t happen right away; I haven’t timed it, but it’s probably about 10 minutes after I start the operation before the error occurs.

My Mac is a MacBook Pro (2.53 GHz Core 2 Duo) running 10.6.2. The VM is on an external Firewire drive and I’m trying to create the DMG segments on the MacBook’s internal HD (there’s not enough free space on the external Firewire drive to hold the segments, which is one of the reasons why I’m trying to archive it).

Any ideas? TIA!

How much free space do you have on the destination drive? Have you tried using Always Run With Root Access? The error that you’re seeing is from an OS subsystem below the level of DropDMG, and I’ve seen a few cases where it said that it had “timed out” when the actual problem seemed to be that it didn’t have enough file privileges.

There’s plenty of space on the destination drive (about 150 GB), but after setting DropDMG to run as root it was able to actually start creating the DMG file. Thanks for the tip, Michael!

…and then I got hit by the OS bug that creates a first segment that’s too large for the disc. (“The disc has 8152.0 MB available; 8164.8 MB are needed.”) I guess I’ll try 8130 MB segments and see how that goes.

Sorry to hear that. I reported that bug to Apple in 2006, and they said they were not able to reproduce it.

Well, fooey! Now I can’t burn the first segment. I dropped the segment size down to 8130 and I ended up with an 8143.8 GB first segment, which should fit just fine on a 8152 GB DVD+R DL. However, I keep getting

 Error “The disc drive didn’t respond properly and can’t recover or retry.”

messages at the end of the burn. I even tried dropping the segment size down to 8000, but I still get the error message at the end of the burn (before verification). It’s strange that I was able to burn a 5 GB DMG earlier on the same media and hardware. (The media is Verbatim’s DataLifePlus DVD+R DL, which is supposed to be one of the most reliable DL discs in SuperDrives.)

And, yeah, I’ve rebooted and tried burning the disc with nothing but DropDMG running.

I don’t think this is a DropDMG problem, but if anyone out there has suggestions I’m all ears.

Just got back from the Apple Store and they’ve determined that the DVD drive in my MacBook Pro is faulty. So, I have to figure out how to survive three days without my Mac while they replace the drive. :slight_smile: Then maybe I’ll finally be able to use DropDMG to archive off that old VM! And, once I’ve done that I’ll shoot Michael a payment for a license and the saga will be complete.

Thanks for the follow-up. I’m sorry to hear about your drive, but it’s nice to know the cause of the problem.

The new drive worked like a charm and I was able to finally archive that old VM. Thanks, Michael, for such an easy-to-use product–license payment sent!