C-Command Software Forum

Help please. Mojave Mail - can't get SpamSieve to show commands in Mail

Hello. I just recently upgraded to Mojave (clean install) a few days ago and then used the migration assistant app to transfer my files from a back-up drive of my boot drive in the older OS to the boot drive. I have been having problems getting SpamSieve (SS for short) to work properly - I can’t get SS to show commands in Mail. Here is what I have done so far:

  • I installed a fresh copy of SpamSieve (SS) and then followed the process to install the Apple Mail plug in. SS has full access within the Security and Privacy section and the SS.mailbundle has been applied in Mail.
  • I have followed all the instructions in 7.13.2 of the manual, including troubleshooting using terminal and here are the results:
    Last login: Wed Jun 19 17:37:29 on console
    Restored session: Wed 19 Jun 2019 17:35:50 EDT
    Lyles-Mac-Pro:Preferences lyle$ cd ~/Library/Containers/com.apple.mail/Data/Library/Preferences/
    Lyles-Mac-Pro:Preferences lyle$ /usr/libexec/PlistBuddy com.apple.mail.plist -c ‘Add EnableBundles bool YES’
    Error Reading File: com.apple.mail.plist
    Lyles-Mac-Pro:Preferences lyle$ killall -SIGTERM cfprefsd

I then used AppCleaner to remove SS, then reinstalled and went through the entire setup process again - and the SS commands (for ex., SpamSieve-Train as Spam) is still not showing up.

Once this is solved, I was planning on copying my training data, as per 7.12.4 of the SS manual.

The only thing that I can think of that may be having an effect is that, while using El Capitan, I moved my home folder from the SSD boot drive to a data HD in order to keep the SSD “optimized for speed” (I used the instructions from this article: https://www.lifewire.com/move-macs-home-folder-new-location-2260157) . I did notice that the Migration Assistant refused to import any files for my work account (but did transfer the other accounts’s data, the applications etc.), but I reasoned that this was OK, as I still have access to all the content from my El Capitan account on the backup as well as continue to use the data drive.

I am also wondering if I may have a made a mistake by naming my work account the same in Mojave as it was in El Capitan. I just assumed that once I had everything setup in this account that I could then move my Home folder to the data drive, as I did when using El Capitan.

Any suggestions would be much appreciated!
Thank you.

Did you follow the part in that section where it says to check the box in the “Manage Plug-ins…” sheet?

Is your home folder still on a different volume than the system now that you’re using Mojave?

That should be OK.

Solved … but not quite sure how.
Hi Michael. Wow, fast response by you - thanks!

I did check in Mail preferences for the plug-in … everything seemed OK. However, I did see another plug-in from Druide Informatique (Antidote 10 Spell checker French and English - integrated with Mail and with Outlook). I unchecked both the SS plug-in and the Antidote plug-in and closed Mail.

Since Antidote was giving me problems with Outlook (their Connectix service wasn’t functioning) and with Mail, I decided to uninstall it with AppCleaner. I also uninstalled SS.

I shut down the Mac Pro, then restarted it. I installed SS, made sure that it had Full access in Privacy-Protection, opened Mail, rechecked the SS plug-in, closed Mail. Shut down the MP.

Restarted the MP, checked Mail and the Spam Sieve commands were now present! Finished the setup and decided not to transfer the training data after all. SS seems to be running fine now (still working on Antidote). Just in case you were wondering why I am using 2 mail clients … Outlook is used at the request of a client who has given me an email account with them - I have access this way to the company directory etc.). I am wondering if one of the problems with SS was that I installed Antidote first, followed by SS? I really don’t know.

Home folder is still on the Mojave boot drive, for now. Thanks for letting me know about the account naming not being a problem.


Glad you got it working! I don’t know. I haven’t heard of that being an issue before, but please let me know if re-enabling Antidote causes any problems.