C-Command Software Forum

how to prevent Skim from incorporating EF library search phrase

Hi,

I am seeking a way to disable the following behavior:

When I do search in my EF library, say for “dog”, I get a returned list of documents with the word “dog” in them.

If I then open one of those search results which is a PDF, Skim (my default PDF viewer opens and displays the PDF

When Skim opens the PDF, it automatically picks up the search term/phrase I used to search for the document in EF.

This isn’t always such a bad thing, but it gets in my way more often than not. Typically I find myself searching for the document with one string and then search for a more specific or different string when I within the document itself.

Is it possible to prevent Skim from using and/or prevent EF from sending the EF search string?

I didn’t see anything I could set in Skim to prevent it and haven’t found a way yet in EF. Though, I did fine the esoteric setting “ClearSearchWhenChangingSources”, which, while not solving this problem, is something I like. :slight_smile:

Thanks,
Mike

There’s currently no way to prevent EagleFiler from sending the search string. I’m not sure whether there’s a way to make Skim ignore it.

This behaviour has bugged me too.

My workaround has been to search for a text snippet, then select the relevant item, then emptying EagleFiler’s search box (the relevant item remains selected), and only then opening Skim.

Works, but far from ideal I grant you that.

Cheers,
istib

I must be missing something here. Why is the above easier than just clicking the X button in Skim to abort the search?

With EagleFiler 1.5.3 you can click this link to prevent it from sending the search string.