C-Command Software Forum

How to restore “deleted” files?

Today, I deleted some records by mistake (move to Trash and Empty Trash).

In a panic, I restored them into their original folder ~/library name/Files/subfolder/ ] via Time Machine.

As I could not confirm whether they really come back, I tried to do “Update Checksum” and this shows a bit progress bar in Activity window and results with no error message.

After that, I did “Verify” and then EF answered : Verification Results for “library name”, Files verified: 2,070, Failures: 0.

Action “Delete” seems to be external Application for EF, however, EF might be able to know missing of files via reindexing…. Now I a bit confused.

My above actions are correct? If not, please teach me better way to restore.

Emptying EagleFiler’s trash deletes the files and removes EagleFiler’s references to them. When you do a Time Machine restore, that restores the files, but it doesn’t tell EagleFiler that they’re back. You need to move the restored files outside of your EagleFiler library and then import them.

Thank you for kind reply to my elementary question.

I fully understand how to restore “deleted” files.

By the way, after posting, I can find that these files really come back in [library name/Files], NOT in [library name/Files/subfolder]. Moreover, I cannot find subfolder itself.

Time Machine restored these files in the style of [library name/File/subfolder].
After the above reindexing, however, EF seems to arrange these files from [library name/Files/subfolder] to [library name/Files] and deleted subfolder.

Is it correct for EF? Or, I still misunderstand?

EagleFiler will arrange the files wherever you put them. If you don’t tell it what to do, e.g. if you drag and drop onto EagleFiler’s Dock icon, it will put them at the top level (in Files). If you drag into a particular folder in the EagleFiler window (or if you use Capture With Options) you can specify a specific subfolder.

Your advice is just match to my experience. I fully understand.

Thank you for your kind reply as always.