iCloud email out of control with Spam

We host our own company mail server (Kerio Connect) which we run though SpamTitan, which works pretty well as far as controlling spam, using AppleMail on our Macs. However, the amount of spam we receive through iCloud is out of control, and SpamSieve has yet to help at all. I have manually gone through the Block List to make sure the spam emails are tagged correctly, but to no avail. I have even tried to block their IP address range in SpamSieve, but I am not sure it is designed for this. I have also forwarded them to spam@icloud.com, but nothing seems to slow them down. Any ideas other than to close my iCloud account and start over?

None of that should be necessary. It sounds like something isn’t set up properly. Have you trained the uncaught spam messages as spam? Please check the setup or send in a diagnostic report.

It’s a new bug or something. It defeats regular spam or junk mail. I got SpamSieve to start catching some but be careful on a Mac- it wiped out my entire email inbox using Apple Mail. I had to go back to outlook and I’m tentatively working through the problem. But whatever that spam bug is, it’s new and it’s aggressive. I’ve never seen anything like it. Took up my entire email to the point I could barely use it.

Same problem here. Just joined the forum for help on this.

I have not heard back from @ccourson1 so it’s not yet clear what the issue is. @Mia and @scchang, please check the setup or send in a diagnostic report so that we can help you.

What I did today was forward my iCloud emails to my Corporate server, which routes through SpamTitan. What a difference. In the end, I get almost no spam now, versus SpamSieve. Don’t ask me why , but SpamTitan catches the spam and it NEVER hits my inbox, albeit regular mail or junk, so I don’t have to deal with it. I am happy!

SpamSieve Log.log (1.08 MB)

In your case, it looks like the spam messages are not getting through SpamSieve. Rather, it never looked at them, either because of a setup problem or because the messages were marked as read or moved out of the inbox before they got to your Mac. There is more information about troubleshooting this here.

Also, there were no messages trained as spam on February 21, so perhaps the problem is no longer occurring?

Well, I haven’t changed any settings or my practices. The only thing I’ve noticed is that the Mac Mail junk mailbox has started to fill up much much faster than ever before. I have “Enable Junk Mail Filtering” off as always.

They don’t even hit SpamSieve because the bug is programmed to be email. It defeats any filter. With regular spam, which I know nothing about, you can mark mail from a particular address as junk. This bug has no address. All the emails in the “from” address (again, which I know nothing about) are empty. There’s no way for any filter to catch them.

The standard setup is for SpamSieve to move the spam messages to that Junk mailbox. So if it’s filling up, that means you are being sent lots of spam messages but that they’re being caught automatically. As I said, the log shows that SpamSieve didn’t miss any yesterday. If that stops being the case, please let me know.

I have not seen any evidence of this bug. It doesn’t matter to SpamSieve if the address is empty. Do you have a link to more information about what you are referring to and how it’s affecting other filters?

If you do find a message that you think is triggering a SpamSieve bug, you can report it as follows:

  1. Choose File ‣ Save As… in Mail and save it as a file in Raw Message Source format.
  2. Select the file in Finder and choose File ‣ Compress.
  3. Attach the .zip file to a new e-mail message and send it to spamsieve-fn@c-command.com.