C-Command Software Forum

import from devonthink error

Just a quick note. When importing a bunch of entries from devonthink using F1 I ran across many errors. I then sorted by date in Devonthink and all were imported without a single error. Don’t know why but maybe of some interest to someone.

Where were the errors displayed? What did they say?

EagleFiler encountered an AppleScript error while trying to capture from DEVONthink Pro.

Can’t make missing value into type POSIX file. (line 13)

It was the same error on all and happened on every folder I tried to import. I also just muIti selected a bunch of entries and received the same error. I finally just drag&drop everything one at a time and that worked fine.

Thanks. I’m not seeing that error on my Mac. What kind of files were they? Which version of DEVONthink are you using?

What happens is that EagleFiler asks DEVONthink to export each file. DEVONthink is supposed to report where it saved the file, and then EagleFiler looks in that location and imports it. The error means that DEVONthink reported a “missing value” instead of saying where it had exported the file.

A variety of files mostly pdfs and mail captures. I am using the latest 1.5x version. The database is only about 350 MB. I will make a new library today and do it again to see more specifically if you are interested.

Update: I just created a new library and did this all over again and everything worked fine. How strange, I hate when the gremlins just disappear. Sorry for the bother. I think I will get rid of the first library all together and go with the one that had no errors.

EagleFiler 1.4.4 improves the error message so that if DEVONthink is unable to export a file, EagleFiler will tell you which one.