C-Command Software Forum

“Improve sound quality” feature not working after putting AirPods Max aside

I have the same problem. Works with the first connect, but after that, everytime i put my AirPods Max aside (keeping them connected) and put them on again, microphone input changes back to the AirPods Max micro and makes the sound of the whole system audio terrible telephone quality.

Is there any fix for that or is that beyond Tooth Fairys possibilities of controlling macOS? The scripts didn’t work for me either (yet), will keep on trying.

You say that it works with the initial connection, so think you are actually seeing a different issue here. When you put the AirPods Max aside (or take regular AirPods out of your ears), macOS does not see that as disconnecting. And it does not see putting them back on as connecting.

The Improve sound quality option only comes into play when macOS says that the device is connecting. If the sound input changes but macOS does not report that the device is connecting, ToothFairy won’t notice and so won’t fix the sound input.

So I think the question is, why is the sound input changing when the AirPods remain connected? (On my Mac, removing but not disconnecting the AirPods does not change the sound input setting in System Preferences.) Are you able to figure out when this is happening and if it’s linked to particular software or actions on your Mac?

Regardless, you can probably work around the problem by tapping the hotkey twice so that ToothFairy disconnects and then connects the AirPods.

1 Like

Thanks for your answer, very appreciated! This is strange – if macOS keeps the connection of the AirPods Max/Pro when putting them aside and back to the ears (which it does indeed and is logical), Tooth Fairy wouldn’t change anything again, of course – but the input also shouldn’t switch back automatically to the AirPods mic which it does when putting them back in my ears. As far as I can see, this isn’t influenced by any software and action as it is done universally by macOS in any situation.

If this shouldn’t happen, I’ll keep trying to find the solution to this. Thanks for the hint with the hotkey, though, that’s better than nothing. (Although I would definitely appreciate to find a “real” solution.)

Thanks again!

Apple doesn’t document what’s supposed to happen, but for me and most users I’ve heard from it does not switch the input. However, I do know of a few people who are seeing what you’re seeing. That’s why I think it may be linked to something specific about your Mac. You could see whether rebooting in Safe Mode helps.

I will also try to find a workaround that’s more automatic than using the hotkey.

1 Like