C-Command Software Forum

Indexing - too frequent & hangs?

Since my switch to Lion, I’ve noticed that “indexing records” is happening not just almost all the time, but is “hanging”. When switching back and forth between EF and other applications, it delays EF becoming live (that is, e.g. recognizing the cursor either in the text space, on the scroll bar, or in selecting a file from the file list). After several seconds, the cursor will come alive while the indexing (spinning ball indicator) continues for some time more. This even if I made only tiny changes (e.g. deleted a space) to only one record only 30 seconds prior.

When indexing, it also seems to slow down other functions (scrolling, navigating in the text window, styling a text selection, etc.) When I check the Activity Window, it shows that indexing is almost complete, but the progress bar remains in that position for many seconds and sometimes minutes - again, even if only a minor change was made in a single record.

I’ve re-checked my preferences to make sure that I’m not copying tags to Spotlight. That option created an indexing slow-down problem for me in Snow Leopard, and I have no need for Spotlight to search tags, so I got rid of it and got major speed improvements.

Is there some other preference setting I’m likely to have overlooked that’s producing this difficulty? Or is this just a kink that will likely get worked out over time in new Lion or EF versions?

Any recommendations?

Please describe what you mean by “hanging.” Does it get stuck showing the same number? Are you able to cancel the indexing by clicking the X button?

It sounds like you’re saying that it doesn’t get stuck or truly hung, that it’s just abnormally slow?

I’ve not received other reports like this, so most likely it’s related to something about your library, hard drive, or Mac. Do you see errors in the log?

similar effects when indexing
I’m seeing something that sounds similar, but it’s not very frequent so I ignore it.
“From time to time,” EF seems to slow down. Sometimes the fans on my mac get loud, and when I check CPU utilization, I find that an activity EFindex (or something similar) is running at about 100% utilization of one thread (out of 4 threads). The processor is heating up, which is why fans get loud.

In either case, when I check EF activity window Cmd-0, it is indexing.

This is after I’ve recently added multiple documents, so I figure EF needs time to think! I usually go do something else and come back in 30 seconds.

Hardware: 2010 MBP, i7 2.66 Ghz (4 threads), 8 GB
Lion OS 10.7.2

I want to emphasize that I can live with this, because it’s infrequent and not super-severe. But it might be nice to have some way to disable indexing temporarily.

That could be normal. efindextool is the process that updates EagleFiler’s index files. This can take a long time if there are already many documents in the index and/or you’re adding a document with a very large amount of text.

It could also be abnormal. If the index file is damaged (e.g. because of a disk error or because of force-quitting while efindextool was writing to the index) it’s possible for it to get stuck updating the index file. In this case, you should rebuild the index. The rebuilding process can also be used to switch between phrase and word indexing to adjust that speed tradeoff.