C-Command Software Forum

Internal Error while Importing Mailbox

I’m battling getting Apple emails imported into EagleFiler.

I select all messages in a particular folder, and press FN-1

Popup says 811 messages copied.

When I look at EagleFiler it says

error: MJTException - <NSError Domain=MJTErrorDomain Code=1002 UserInfo={
MJTCurrentUserName = “mdm”,
MJTFailingKey = “EagleFiler-2020-04-22-sAXFdCi3SHSiaG7ZXw-cwg”,
MJTFailingObject = (
“EagleFiler-2020-04-23-UZxsQyZrSOaKsTR7D7tnYA”
),
MJTFileExists = 0,
MJTFileIsLocked = 0,
MJTFileOwnerName = “unknown-name”,
MJTParentFolderACLString = “”,
MJTParentFolderIsLocked = 0,
MJTParentFolderModeString = “755”,
MJTParentFolderOwnerName = “mdm”,
MJTStackFrames = (
“-[MJTTempFolderManager tempFolderURLWithName:error:] (116)”,
“-[NSURL(MJTFiles) mjtCheckDirectoryExistsError:] (187)”
),
NSFilePath = “/Users/mdm/Dropbox/EagleFiler/mdm-email/mdm-email.eflibrary/Temporary Items.nobackup/iCloudDrive.nosync/EagleFiler-2020-04-22-sAXFdCi3SHSiaG7ZXw-cwg”,
NSLocalizedDescription = “The expected directory was not found.”
}>

I’ve also tried saving those same messages (Raw Message Source) and then putting the file into the To Import folder. Worked the first time, but not subsequent times.

The file disappears from the To Import folder, but does not appear in the Eagle Filer Library. Nothing in Activity nor Errors windows. Can’t find a log file to see what happened.

How should I be trroubleshooting this ?

EagleFiler 1.8.13
Mac OS Mojave 10.14.6

Thanks

mark

Hmmm… this just popped up.

EagleFiler could not save the library.

Could not merge changes.

NSCocoaErrorDomain: 133020

May be related to previous problems.

It looks like you are storing your library in Dropbox and have opened it on two Macs at the same time. This will damage the database file and cause EagleFiler to lose track of files. You can fix this by rebuilding the library. Going forward, please make sure that you follow the Rules for Shared Libraries.

You are most correct. Forgot about that limitation.

Thanks for the fast response.