C-Command Software Forum

IOError: error -22 (Unknown error: -22) for file:

hello All:

I have been using eaglefiler for awhile now, mostly for email archiving and am very pleased with the way it has been working. Since I don’t often make new mailboxes in mail.app, this process is just a matter of capturing the mail from a box to my email library and then merging the new mailbox (or the most recent) with the older existing mailbox.

Today when i tried this, I got the message contained in the title – actually there was more (a path to the mbox of the box i was trying to merge). I tried this three times, with 2 different mailboxes.

Can someone please give me a clue regarding what is going on and/or how to correct it?

thanks.

Please restart your Mac and open the library in EagleFiler. Select Records and then choose Verify from the Record menu. What does it report?

If the verify succeeds, try merging the mailboxes again. If you still get the error, please send in your log file:

/Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

via e-mail.

The problem was solved by replacing the mailbox files with copies from a backup.