C-Command Software Forum

Is there a way to make a .DMG that cannot be used on older OS X?

The software I’m distributing using dropdmg no longer supports 10.6 and older, so I’d like to avoid letting people even try to install it on older versions of OS X. Is there a way to limit what versions of OS X a .dmg will even mount on?

Thanks!

No, that’s not possible except that some of the formats require Mac OS X 10.5 or later. But there are none that require 10.6 or 10.7. You could put some text in your disk image’s background saying which OS version is required, and of course use LSMinimumSystemVersion in your Info.plist file.