C-Command Software Forum

Issue with one of four mail accounts

I was looking at this earlier today and it seemed OK. I tried with the outlook spam filter on and off and get the same results. Her is what mine looks like,

Let me know what you think. Again, no issues with the other three accounts.

That looks fine to me. Have you tested the script in Script Editor to make sure it moves the messages out of each Junk mailbox? (You could also manually move or delete the bulk of the older messages if you don’t want SpamSieve to go through all of those.)

Good Day Michael:

Sadly I wouldn’t even know where to begin to do such a test. I am not any type of a programming person unfortunately. The other three accounts have no issue. They work fine bu the Pitchpipe 52 account tosses everything in to junk mail.

Here is what I got from yesterday. Looks good but ended up in spam……

It looks like you already had the script file open in Script Editor, where you added your account names. So all you need to do to test it is to click the Run button in that window.

Good Day Michael:

So I managed to figure out how to run a test. It just shows two quotes for results… “ “ Don’t know what that tells you. I have been checking the junk folder when I am in my mail so that I can pick out the good ones and delete the real junk. The other three accounts have no issue. They work fine but the Pitchpipe 52 account tosses everything in to junk mail.

The result of the test should be that the Junk mailboxes in Mail are all emptied, with good messages moved to the inbox and spam messages moved to Spam. If that doesn’t happen, you should see errors reported in the Console app. (The easiest way to see them is to enter Server Junk Mailbox in the Console search field before running the script.)

Hello again Michael:

I can not get it to change. Ii is an issue with me for sure but that is what old age gets for you. Should I just remove it and leave it out or maybe reinstall it? Was working great and I never went in and played around with it. Would make more sense (to me anyway} if all four mail programs were not working instead of just one.

Could you explain what “it” refers to?

I think they’re working differently because the mail providers are different.

It just refers to them mail program but only for Pitchpipe52 as the other three work fine. That is the strange part. The other three email address work fine. So, even good addresses come in showing that they are spam. Nothing at all comes in as good even though I have changed it back to good.

Did you try what I suggested above to run the script in Script Editor and see if it moves any messages out of Junk or reports any errors in Console? You can also set pEnableDebugLogging in the script to true to see more information about what it is doing.

Hi Michael:
I have not really played around with this issue over the past several weeks. I have come to the point that I have to go to junk-mail and look for any email that is of importance and move it to my inbox and then delete the junk manually. I have not been able to repair or change this issue but I am not a real computer guy ether.

Please let me know if you have a specific question about how to test the script by running it in Script Editor and looking at error logging. Or, it may be that the problem is something simple like the account name in the script not exactly matching the account name in Mail.

I stuck with my emails, they are not saved in draft.

Sorry, but I’m not sure what “stuck” refers to here. SpamSieve does not affect draft messages.

I mean, I have seen this problem for the last 3 weeks.

Which problem? For example, what did you do? What happened? What did you expect to happen instead?

Hi Michael:

I still have one account that all my email is going to junk. The other three are fine except that one email address is out there and is now getting bombarded with unwanted female companion messages. Can I exempt specific phrases to push these into trash? As for my original issue, I need direction on how to run the script editor.

Thanks,
Jon

You could do that by creating a rule in Mail above the SpamSieve rules.

It’s in the Utilities folder in your Applications folder.

Still no success. All email goes into junk marked as spam whether it is or not. I end up sorting through it and moving the good mail back to the inbox. Still running Catalina so Big Sur is not an issue.
I just lack the knowledge to make the proper corrections it seems.
Can I just remove Spam-sieve from that one Email account and let it run normally?

Yes, please see this page. However, the problem that you described is that Hotmail was putting the messages in Junk. Turing off SpamSieve for that account won’t fix that. That’s why we were trying to set up SpamSieve to do more with that account, to work around the Hotmail problem. I recommend continuing with that. For example, did you ever test the script as I described above?