C-Command Software Forum

Jenkins and DropDMG on BigSur

I am trying to build my software using Jenkins slave on the newest BigSur.
I had no problem with this scenario on High Sierra, but after update I still get error:

2020-12-04 15:04:24.381 DropDMG[1772:14954] CFURLRequestSetHTTPCookieStorageAcceptPolicy_block_invoke: no longer implemented and should not be called
2020-12-04 15:04:26.648 [com.c-command.DropDMG]  Scripting bridge error: Error Domain=NSOSStatusErrorDomain Code=-1743 "(null)" UserInfo={MJTFailingAppleEventString='core'\'cnte'{ '----':null(), 'kocl':'brow' }
2020-12-04 15:04:26.833 [com.c-command.DropDMG]  Error: <CreateJob: Creating from “Aplikacia_pre_eID”> <NSError Domain=NSOSStatusErrorDomain Code=-1743 UserInfo={
ErrorNumber = -1743,
MJTFailingAppleEventString = "'core'\'cnte'{ '----':null(), 'kocl':'brow' }

My build process consists of login to Jenkins slave and then the shell script is called with command:

dropdmg -g "eID_Klient_conf" $KLIENTDEPLOYDIR

My security settings are:

When I connect to Jenkins slave using remote desktop and I open DropDMG and manually I create dmg file everything is ok.

Am I missing anything with security settings ?

Thanks for your help…

You seem to be missing the security setting for Terminal to control DropDMG:

There is no way to add this manually. However, if you manually invoke the dropdmg tool from Terminal, macOS should prompt you to allow this, and then the access should persist for later when Jenkins needs it.

Thanks Michal for your help.
I tried to invoke DropDmg from Terminal and then I allowed access but in security setting it added me only permission for Terminal and Finder, not Terminal and DropDmg (screen from my previous message). I was doing this on fresh clean installation of BigSur.

When I uncheck Finder from Automation security settings it gives me error

Error Domain=NSOSStatusErrorDomain Code=-1743

which is the same error as from Jenkins. So you are right with missing security settings, but I am not able to add permission Terminal and DropDmg

I’m not sure why that isn’t working for you. When I invoke dropdmg from Terminal, I get this:

and then after I click OK it shows this:

privacy-terminal-dropdmg

Perhaps there is a problem with your TCC database. You can reset it with this Terminal command:

tccutil reset AppleEvents

and then hopefully it will show you the right prompt.