C-Command Software Forum

Layout incorrectly applied?

Hi, I’m using DropDMG 3.5.4 on macOS High Sierra 10.13.6 with a MacBook Pro 15” 2016. Whenever I create a layout and select it in the current configuration, and then create a dmg file, it’s correctly created (including the icons added to that layout) except for the background image and icon positioning. This happens by using a blank background or any background image, and any icon positioning. I tried removing all preference files and rebooting, but this issue persists. I found a copy of 3.5.2 as well, and I had the same issue. I tried showing hidden files in the resulting dmg, and I found a “.DropDMGBackground” folder with the background image.

Sorry to hear that. I have not heard other reports of that happening, so I’m not sure what would be causing that. Please click this link to enable some debug logging. Then restart your Mac in Safe Mode. As soon as the Mac boots, try creating your disk image again with DropDMG, and if it doesn’t work properly, send in a diagnostic report. Thanks!

It may also help to click this link this link to make DropDMG set the background picture multiple times. That can sometimes help if Finder doesn’t save it properly the first time.

Just to add a “me too” on this, experiencing the same issue running DropDMG on 3.5.4 on macOS High Sierra (10.13.6).

Going to try your link to see if that resolves and will report back!

I had the same issue and I’m pleased to say that the link you provided resolved the issue.