C-Command Software Forum

Leopard, SpamSieve and IMAP

I am using MacOS 10.5 and SpamSieve 2.6.4. Since I’ve updated to Leo, Apple Mail stops properly downloading from my five IMAP Accounts as soon as I enable the SpamSieve Rule (which is the first one in the list). Everything is fine as soon as disable it. Apple Mail just seems to hang - the turning wheel is next to one of the accounts and I have to force quit Apple Mail to close it. SpamSieve opens normally without bouncing, I get the Growl Mail information, but then it just seems to stop - when it stops, there is no more activity showing in the activity monitor of Apple Mail.

Anyone having the same issue or an idea how I can get SpamSieve to work again?

Barbara

I’d like to see what’s happening here. It would be helpful if you could open the Activity Monitor program and select Mail in the list. When you see the spinning wheel, choose Sample Process from the View menu. Then save the resulting data to a file and send it to me.

As for fixing this, it might help to uninstall the GrowlMail bundle.

Re: Leopard, SpamSieve and IMAP
I’m getting the exact same problem. The Activity viewer of Mail shows a status of “Adding Messages” and shows one message being added. The message has already been added, but the Activity viewer message never goes away. Also no new messages after the one that is “stuck” are processed.

I too have disabled SpamSieve with the result that the problem occurs nowhere near as often. With it enabled it occurs with every new message, with it disabled it occurs once every two to three days. So the problem may be with Mail but…

I have emailed the output of Activity Monitor as requested of the previous poster.

Thanks.

I received the sample logs that you sent, and the problem seems to be caused by GrowlMail.

1179 Thread_3203
  1179 thread_start
    1179 _pthread_start
      1179 __NSThread__main__
        1179 -[NSThread main]
          1179 +[WorkerThread _execute:]
            1179 -[MonitoredInvocation invoke]
              1179 -[NSInvocation invoke]
                1179 __invoking___
                  1179 -[LibraryThread _runThread]
                    1179 +[Library addMessages:withMailbox:fetchBodies:oldMessagesByNewMessage:]
                      1179 copyDescriptionFormatString
                        1179 GetGrowlMailBundle
                          1179 pthread_mutex_lock
                            1179 semaphore_wait_signal_trap
                              1179 semaphore_wait_signal_trap

When you install SpamSieve it tells Mail to load plug-ins, and Mail loads all of the installed ones. Before you installed SpamSieve, GrowlMail was probably dormant. So I think if you remove the GrowlMail.mailbundle file from:

/Users/<username>/Library/Mail/Bundles
or:
/Library/Mail/Bundles

it will work again.

re: Leopard, SpamSieve and IMAP
Thanks Michael. I’ve disabled growlmail and we will see how it gets on.

Damian.

Re: Leopard, SpamSieve and IMAP
All good. Disabling GrowlMail has fixed the problem.

Nothing to do with your great software at all.

Thanks very much for your assistance.

Regards,

Damian Halloran.

Same here - and thank you not only for the wonderful software, but also for the great support!

Barbara