C-Command Software Forum

Library Corruption?

I’m using EF 1.2 with the library on a samba share.

I’m getting the following error: “Could Not Read Library. Failed to save. Unknown store type, format, or version. NSCocoaErrorDomain: 134000”

This error occurred after I tried dragging a large folder c/w subfolders and lots of files into EF. I then clicked on the folder presumably before it was done importing.

Any way out of this?

–Dave

If you quit EagleFiler and re-launch it, are you able to open the library? Does it work if you copy the library to a local volume?

I get the same error when re-launching; I’ve tried a few times. I’ll try it on the local volume when I get back to the office Friday. Do I need to move the entire “Files” folder as well? Well, easy enough.

–Dave

Yes. If you can’t get it to work on a local volume, please e-mail me the .eflibrary file and I’ll see if I can figure out what’s wrong.

Well, that was interesting. I copied everything to the local volume and it opened up just fine. I copied it back to the server share (under a new folder name) and now it works again. So it looks like I’m good to go!

Could this issue be related to using samba? We plan to install a Mac server here shortly so samba will not be part of the equation in the future.

Thanks for your help.
–Dave

Perhaps. Or maybe there was a permissions problem. Core Data supports Samba, so EagleFiler should be fine with it, provided that the server is working correctly.

rather than start a new topic i’ll try putting it here since it might be related. i am new to EF and i am storing my very small library on pCloud which is a volume mounted with FUSE. after a certain amount of time i am consistently getting a domain error ‘could not save library’ which i think is related to where it is stored. so far with library located on a local volume i am not getting the error. is there any way around this?

I’ve heard of the issues with pCloud, such as it not supporting certain characters in filenames, but I haven’t seen that error before. Were there more details (such as an error number) in the error dialog?

Please note that if you use a cloud service to open the same library on multiple Macs at once, they might try to write to the database at the same time, which could damage the file. There are guidelines here for safely sharing a library between Macs.