C-Command Software Forum

Local vs. IMAP spam folder

I’ve just set up a customer (IMAP account, running Mail.app on a MacBook Pro running 10.5.5) with SpamSieve 2.7.3, but I cannot get SpamSieve to route “Train as Spam” messages to the user’s IMAP-based spam folder. It instead creates a local folder of the same name, despite repeated use of the “Change Settings” process that normally would clear this sort of thing up.

The SpamSieve rule is set to direct auto-processed mail into an IMAP spam folder – that much is working properly.

I also tried quitting out of Mail.app and SpamSieve and then ditching the com.c-command.SpamSieve.plist file (starting fresh), hoping there was something mangled in there, but it didn’t make any difference.

The only thing remotely different about this user is he uses the Letterbox three-pane plugin for Mail, but I can’t imagine why that would affect SpamSieve’s routing?

Thanks,

Brian Reichow

Please make sure that the IMAP account containing the Spam mailbox is the first one listed in Mail’s Preferences window and that the name of the mailbox exactly matches (including case) what’s entered in Change Settings.

Solved
The IMAP account in question was in fact listed 2nd in Mail.app’s account setup window. By moving it to the first position, quitting and relaunching Mail, and then going through the Change Settings process, it now works.

Fantastic call on that one!

-Brian

It seems I have a similar problem.

I have three IMAP accounts and one POP account and would like to make sure that SpamSieve moves junk mails into the standard Apple Mail junk folder. For that purpose I followed your instructions in the manual.

However, SpamSieve moves junk mails into a (newly created) local junk folder; not only trained mails but also all incoming mails marked as junk by SpamSieve (and Mail). Also I have noticed that the mail rule has changed from the (standard) junk folder to the new local junk folder automatically.

I tried to redirect the rule but after this Mail has shown the spinning beach ball and I had to go back to the previous setting via Time Machine…

Any ideas?

Thanks,
Thomas

The incoming messages will go wherever the rule points. Unfortunately, if you are unable to modify the rule, that’s a Mail issue, not a SpamSieve issue. It’s possible that your Mail database is damaged. You could quit Mail and delete the file:

/Users/<username>/Library/Mail/Envelope Index

Then it will build a new database for you.