C-Command Software Forum

location in text jump-scrolls / auto-scrolls towards the bottom on its own

i am editing text that i have in an rtf record. suddenly the text in front of me jumps from where i was working towards the bottom of the record, often to the end of my record / rtf tile.

i then have to scroll up to find where i was.

this happens every 2 to 3 minutes, perhaps when the program auto-saves.

it’s a really annoying time sink especially when what i am editing is more than one page long.

i am using eaglefiler on a MacBook pro system 10.14, but same thing happened in previous versions of the operating system.

this does not happen with any other application, eg ms word.

any way to prevent this?

That sounds really annoying. I’m not sure what’s causing it, as I don’t see that behavior here, and it’s not designed to work that way.

Does the insertion point or selection change? Or just the scroll position?

Auto-saving happens every 1 minute and, as far as I know, doesn’t trigger any changes to the display.

So I’m wondering what else might be related to this or help trigger it:

  • Are you switching back and forth between windows in EagleFiler or another app, or is this all happening while working in the same window?
  • Is a search active in the toolbar of the EagleFiler window?
  • Is the file stored in a folder that syncs with Dropbox or another similar provider?
  • Is there anything else that might be modifying the file while it’s open in EagleFiler? If EagleFiler detects that the file has changed, it will reload it and try to restore the insertion point and scroll position, but perhaps something is going wrong during that process, causing it to scroll to the bottom.

thanks for your help.

definitely the scroll position changes. i am not sure about the insertion point. i have tried to check this by typing, hoping that typing will return me to the previous insertion point. but typing does not correct the scrolling. i have hesitated to type much if i can’t see exactly where i am typing. oh, i just found something: right now, i can see both eaglefiler and firefox side by side in may big monitor. i stop typing in this forum in firefox and click in my record in eaglefiler and place an insertion point where i will remember it. as soon as i click back to this forum in firefox, the insertion point in eaglefiler disappears. the insertion point also disappears if i use command tab to switch out of eaglefiler. if i click back on the eaglefiler window (i would usually click at the top or side when i don’t know where my insertion point was), the insertion point does not reappear. but if i use command tab to switch back to eaglefiler, the insertion point does reappear. i just tried this in ms word, and the insertion point in my word document disappears when i click on firefox but, unlike with eaglefiler, the insertion point reappears when i click anywhere in word.

ok, i found something else. if i set an insertion point in eaglefiler, switch to firefox, and switch back by clicking within the record window, the insertion point reappears in the correct spot. unfortunately, if i set an insertion point and then scroll so i can no longer see the insertion point, switch to firefox and then switch back by clicking within the record, the record does not jump back to the insertion point. just checked and this is also true in ms word.

mostly, unsure if always, happens if i have checked another app - such as responding to your kind message. usually i am constantly going back and forth between eaglefiler and emails or notes where i have something i want to add to my eaglefiler
no search is active.
i do not sync with dropbox or another similarprovider.
i agree with you that it seems to be acting as if i have modified the file, but i have no idea what i may have done.

when does the jump occur
does this help? i just copied a paragraph from higher in the rtf to an insertion point lower in the rtf, and the scroll immediately jumped to the bottom (2 pages below the insertion point). and the insertion point disappeared - at least i can’t find it.

when does the jump occur
just now i had typed and was simply looking at the rtf, when it scrolled down about a page, and the insertion point disappeared.

when does the jump occur
just now jumped down a page when i was just looking at it. typed a nonsense sentence to try to find the insertion point, and - i think - the typing went in at the correct insertion point.

when does the jump occur
jump-scrolling on it’s own once or twice a minute while i am doing nothing but look at it.

testing the insertion point by typing nonsense, and the insertion point is there unless i have just pasted something.

Is there anything going on in EagleFiler’s Activity window?

It does reappear when I do that. Where are you clicking in the window?

Please e-mail me and I’ll send you a debug build that logs when EagleFiler thinks you’ve modified the file or intentionally changes the scroll position.

i have never looked at the activity window. i just opened it and typed a few test sentences, and it is not jump-scrolling today, so i can’t tell. i worked on with eaglefiler about 8 hours yesterday, and i am done for a few weeks with any major editing. so i may not be able to tell for a while.

thanks,

john

i just emailed you.

thanks,

john

if i cllck within the record window, it reappears.

if i click at the left side list in the blank area below the tags, which commonly happens when i am using another app such as mail that is overlapping the record window, the insertion point does not reappear.

thanks,

john

If you click in another pane of the window, such as the source list, that pane will get keyboard focus. That is why the insertion point will disappear. However, it should still be in the same place if you tab back to the viewer pane.

just tried, and i can’t get it to work that way. if i click on the source list, the insertion point disappears. if i then click back on the window, the insertion point appears wherever i click (or more precisely, on the line i have clicked, just right of the last typed character), not at the point where i was typing before. so i have to know exactly where i was, which is really hard when the window has jump-scrolled.

Yes, if you click it will put the insertion point where you clicked. But you can press the Tab key to change the focus without moving the insertion point.